Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1043640 - need to be able to omit ipappend from pxe file
Summary: need to be able to omit ipappend from pxe file
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Beaker
Classification: Retired
Component: lab controller
Version: 0.14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-16 19:18 UTC by Bill Peck
Modified: 2018-02-06 00:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-24 07:09:39 UTC


Attachments (Terms of Use)

Description Bill Peck 2013-12-16 19:18:04 UTC
Description of problem:
Have an interesting problem.

We have a host that has two NIC's.  First nic is able to pxe boot but the OS doesn't support it.  Second NIC is supported by OS but isn't able to PXE boot.

System was configured to pxe from first NIC and ksdevice= was set to configure second card.

Problem is that dracut on RHEL7 will ignore all other options if BOOTIF= is defined.

I'm hoping we could add the ability to pass no_ipappend2 or !ip_append2. If that is defined then don't write ipappend 2 in the pxe entry.

Code snippet:

    config = '''default linux
prompt 0
timeout 100
label linux
    kernel /images/%s/kernel
    ipappend 2
    append initrd=%s %s netboot_method=pxe
''' % (fqdn, initrd, kernel_options)


Version-Release number of selected component (if applicable):
0.14

Comment 3 Nick Coghlan 2013-12-16 23:58:05 UTC
Does the same system work with the existing Beaker settings in RHEL6?

And if so, wouldn't that make this a backwards incompatible regression in RHEL7 rather than a Beaker RFE?

Comment 4 Bill Peck 2013-12-17 01:42:37 UTC
I will check with Paul Tomorrow.  But even if it does I think its a valid RFE.

Comment 5 Nick Coghlan 2013-12-17 01:55:08 UTC
Agreed, but it makes a difference to the priority if there's an inbound fix to RHEL7 itself to continue honouring ksdevice even if BOOTIF is set.

Comment 8 PaulB 2013-12-17 21:30:15 UTC
All,
Here is a snip from the console out from attempted RHEL7 install:
<-SNIP->
dracut-cmdline[102]: ///lib/dracut/hooks/cmdline/28-parse-anaconda-net.sh@34(source): BOOTIF=01-94-de-80-aa-f9-74 
dracut-cmdline[102]: ///lib/dracut/hooks/cmdline/28-parse-anaconda-net.sh@35(source): '[' -n 01-94-de-80-aa-f9-74 ']' 
dracut-cmdline[102]: ///lib/dracut/hooks/cmdline/28-parse-anaconda-net.sh@36(source): warn ''\''ksdevice=<MAC>'\'' is deprecated. Supplied BOOTIF takes precedence.' 
dracut-cmdline[102]: //lib/dracut-lib.sh@49(warn): echo 'Warning: '\''ksdevice=<MAC>'\'' is deprecated. Supplied BOOTIF takes precedence.' 
dracut-cmdline[102]: Warning: 'ksdevice=<MAC>' is deprecated. Supplied BOOTIF takes precedence. 
<-SNIP->

Best,
pbunyan

Comment 9 Nick Coghlan 2013-12-18 02:20:46 UTC
Bill is going to follow up with the dracut folks to find out more about the reason for introducing the backwards incompatible change, and their recommended alternative approach.

We'll then let the Beaker RFE be guided by what they suggest.

Comment 11 Dan Callaghan 2014-01-20 22:57:19 UTC
(In reply to Bill Peck from comment #10)
> https://bugzilla.redhat.com/show_bug.cgi?id=1044623

Okay great. If I'm reading that right, then the affected systems can add rd.bootif=0 to kernel options. So we can close this RFE as WONTFIX?

Comment 12 Dan Callaghan 2014-03-24 07:09:39 UTC
Solution is to add rd.bootif=0 to kernel options, if a particular recipe or system needs BOOTIF to be ignored by Dracut.


Note You need to log in before you can comment on or make changes to this bug.