Bug 104376 - RFE: easy configuration of quagga daemon parameters
RFE: easy configuration of quagga daemon parameters
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: quagga (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-13 20:19 EDT by Kaj J. Niemi
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.96.2-5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 15:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.spec enabling the above mentioned functionality (9.31 KB, text/plain)
2003-09-13 20:22 EDT, Kaj J. Niemi
no flags Details
patch to enable /etc/sysconfig/quagga functionality in all init scripts (4.28 KB, patch)
2003-09-13 20:23 EDT, Kaj J. Niemi
no flags Details | Diff

  None (edit)
Description Kaj J. Niemi 2003-09-13 20:19:19 EDT
It would be nice if all the quagga daemons would take keep their parameters in a
single place, such as /etc/sysconfig/quagga. Otherwise, to change any of them,
one would have to edit the /etc/rc.d/init.d/blah script.. Sane defaults could
also be provided -- just listen on the loopback interface instead of on all
interfaces.

Attached is a SRPM based on quagga-0.96.2-1 from Rawhide enabling the above
mentioned functionality.

Since it seems like zebra is on the way out this supercedes bug #101317.

Thanks.
Comment 1 Kaj J. Niemi 2003-09-13 20:22:36 EDT
Created attachment 94480 [details]
.spec enabling the above mentioned functionality

Whoops, SRPM > 1000 kb. Attaching just the patch and .spec instead.
Comment 2 Kaj J. Niemi 2003-09-13 20:23:33 EDT
Created attachment 94481 [details]
patch to enable /etc/sysconfig/quagga functionality in all init scripts

Note You need to log in before you can comment on or make changes to this bug.