Bug 1044082 - BPEL Console - **STILL** can't be loaded on IE8/IE9/IE10
Summary: BPEL Console - **STILL** can't be loaded on IE8/IE9/IE10
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: unspecified
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER8
: 6.0.0
Assignee: Eric Wittmann
QA Contact: lvaskova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-17 18:55 UTC by Eric Wittmann
Modified: 2014-02-06 15:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The BPEL Console will not load in Microsoft Internet Explorer versions 8, 9 and 10. This is due to an issue with GWT and the version of Adobe Flash supplied. Try upgrading to the latest versions of Microsoft Internet Explorer and Adobe Flash to work around this issue.
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1032947 0 unspecified NEW BPEL Console - can't be loaded (hangs on loading screen) on IE8/IE9/IE10 2021-02-22 00:41:40 UTC

Description Eric Wittmann 2013-12-17 18:55:08 UTC
Description of problem:

Can't load BPEL console in Windows using Internet Explorer 9.

How reproducible:
every time

Steps to Reproduce:
1. run server (operating system: Windows Server Enterprise)
2. go to: http://localhost:8080/bpel-console/
3. bpel console is not able to load

Comment 1 Eric Wittmann 2013-12-17 19:00:55 UTC
This bug is only hit once BZ 1032947 (see attached) is fixed or worked around.  Once it is, then we end up hitting this error:

07:57:02.618 [ERROR] [app] Failed to create an instance of 'org.jboss.errai.workspaces.client.Application' via deferred binding 

com.google.gwt.core.client.JavaScriptException: (InvalidCharacterError): InvalidCharacterError

@csadilek came up with a possible solution here:

https://bugzilla.redhat.com/show_bug.cgi?id=1032947#c4

I tried this and it worked!  So this problem should be fixed as of ER8.

Comment 3 Eric Wittmann 2014-01-27 18:47:45 UTC
I believe we are having some trouble confirming that the "Install Flash" workaround is sufficient for all browsers because one of the primary QE environments for testing IE is Windows Server 2012.  Apparently this version of Windows comes with Flash already installed, but not *activated*.  I have been able to confirm that the BPEL console will not load by default in this environment.

However, I have not been able to install Flash because it is already installed by default but *inactive*.  The instructions for activating are, I believe, here:

  http://kb.tanium.com/Flash_Player_on_Windows_Server_2012

I have requested that eng-ops enable Flash on all Windows Server 2012 VMs in use by QE but I have not heard back yet (ticket #275296).

I am reasonably confident that this issue will be resolved once Flash is enabled in IE on Windows Server 2012 but I have not yet confirmed this.

Comment 4 Len DiMaggio 2014-01-27 18:50:47 UTC
Do we believe that this IS fixed on Win7, Win8, Win2008?

Comment 5 Eric Wittmann 2014-01-27 18:55:07 UTC
I *believe* it is fixed, based on my testing, which includes the following combinations:

Win 8.1 + IE11
Win 8.1 + IE10
Win 7 + IE10

Comment 6 lvaskova 2014-01-28 14:31:58 UTC
I can't verify it since I'm not able to install flash. 

https://engineering.redhat.com/rt/Ticket/Display.html?id=275296

Comment 7 lvaskova 2014-02-05 12:54:45 UTC
Verified on CR4


Note You need to log in before you can comment on or make changes to this bug.