Bug 1044409 - Project created with business central cannot be built outside business central
Summary: Project created with business central cannot be built outside business central
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: CR1
: 6.0.0
Assignee: manstis
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
: 1049667 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-18 09:26 UTC by Anthony Patricio
Modified: 2014-08-06 20:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:18:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Anthony Patricio 2013-12-18 09:26:43 UTC
Description of problem: Important I don't think this is a duplication of an existing issue.
Using mvn package or install on a project created with business central, seems to work but it created a broken archive.
UF specific files are left, making drools parser fails.


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1- create a project with business central
2- create a simple rule myRule.drl
3- git clone and use eclipse now
4- mvn install -> seems to work
5- now try use your *rule* artifact from another project
6- the rule engine will try to parse remaining UF files (typically a .myRule.drl remaining in META-INF)

Actual results:


Expected results:
I expect the pom to define a phase where it will clean up the .blah UF specific files before packaging.

Additional info:

Comment 3 manstis 2013-12-18 11:28:38 UTC
Mario, when you make the fix we can stop filtering them from within kie-wb when building a KJAR too - and least then we'd be consistent (and have early sight of any other issues later on). Please let me know when you've done the drools-compiler change and I'll update kie-wb. Thanks, Mike

Comment 4 Mario Fusco 2013-12-19 08:41:22 UTC
Mike, I am not trying to compile anymore files having a name starting with a dot ( https://github.com/droolsjbpm/drools/commit/320bb4663 ). 
Reassigning this ticket to you.

Comment 7 Mario Fusco 2014-01-08 08:51:49 UTC
*** Bug 1049667 has been marked as a duplicate of this bug. ***

Comment 8 Lukáš Petrovický 2014-01-26 18:08:00 UTC
There is now a test for this in the Drools community and this test passes when run against CR2.


Note You need to log in before you can comment on or make changes to this bug.