Bug 104441 - Gnome Keyboard Layout Switcher hotkey with X mod keys only doesn't work
Gnome Keyboard Layout Switcher hotkey with X mod keys only doesn't work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
: MoveUpstream, Triaged
: 106345 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-15 13:01 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 14:52:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-09-15 13:01:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I used to have Mod4-Shift_L as the keyboard shortcut to switch the keyboard
layout.  At some point (I think after installing rawhide updates on top of the
initial Severn release), this ceased to work.  `Grab keys'  in the Keyboard
Layout Switcher Preferences -> Options screen still enables me to choose this
combination, but it won't work unless I choose a combination of keys that would
generally cause some character to be input to an application (say, ctrl-alt
along doesn't work, but ctrl-alt-letter does).

I suspect this might be related with the X mod changes that went in around 4.3.0-24.

Version-Release number of selected component (if applicable):
gnome-applets-2.3.7-1 XFree86-4.3.0-29

How reproducible:
Always

Steps to Reproduce:
1.Start keyboard layout switcher, set up two configurations and choose
`Mod4-Shift_L' as the `switch layout' keyboard shortcut
2.Close the preferences window such that changes take effect
3.Use the key combination

Actual Results:  It has no effect

Expected Results:  It should

Additional info:
Comment 1 Mike A. Harris 2003-09-15 19:39:33 EDT
All of the modifier related xkb changes that went into XFree86 that caused
problems with ALT-TAB and other similar issues, were completely removed in
a later package.  I felt the original bugs affected much less users than
having the original bugs fixed but having regressions that affected almost
everyone.

The only xkb fixes that were kept, were small fixes to individual issues,
so I don't think they'd cause this problem for you.  If you'd like to test
however, downgrade XFree86 to 4.3.0-2 from RHL 9.
Comment 2 Havoc Pennington 2003-10-08 18:00:11 EDT
*** Bug 106345 has been marked as a duplicate of this bug. ***
Comment 3 roman 2003-11-16 04:10:34 EST
I have the same problem with FC1 XFree: 4.3.0-42 gnome-applets:
2.4.1-1. Keyboard shortcuts don't switch between keymaps, only
clicking on the applet does.
Comment 4 Spiros Papadimitriou 2004-01-29 05:25:34 EST
I am running RedHat9 (with XFree86-4.3.0-2.90.43) and have had this
problem for a long time: hotkey Alt-Shift_L does not work at all.  If
I try, say Alt-X, from English (label "gkb", command "modmap
/home/spapadim/.gkb_default.xmm") into Greek (label "gr", "setxkbmap
el"; none of the other greek keymaps seem to work), but in the
opposite direction (Greek -> English) no hotkey whatsoever seems to
work.  Clicking on the applet seems to be the only way that really
works.  Furthermore, I had this problem both with the original RedHat
Gnome, as well as with XimianDestkop that I'm running now
(gnome-applets-2.2.2-0.ximian.6.4 is what I have currently installed).
Comment 5 Bart Martens 2004-03-11 14:52:02 EST
The upstream bug report:
http://bugzilla.gnome.org/show_bug.cgi?id=126739

Note You need to log in before you can comment on or make changes to this bug.