Bug 1044481 - Could not initialize class org.apache.commons.net.ftp.FTPClient
Summary: Could not initialize class org.apache.commons.net.ftp.FTPClient
Keywords:
Status: CLOSED DUPLICATE of bug 1044500
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Keith Babo
QA Contact: Jiri Sedlacek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-18 12:05 UTC by Andrej Podhradsky
Modified: 2015-08-02 23:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-18 13:54:52 UTC
Type: Bug


Attachments (Terms of Use)
Error log (6.21 KB, text/plain)
2013-12-18 12:05 UTC, Andrej Podhradsky
no flags Details
switchyard-example (7.45 KB, application/zip)
2013-12-18 12:06 UTC, Andrej Podhradsky
no flags Details

Description Andrej Podhradsky 2013-12-18 12:05:20 UTC
Created attachment 838311 [details]
Error log

Description of problem:
After deploying a SY project with FTP binding I'm getting the following error

java.lang.NoClassDefFoundError: Could not initialize class org.apache.commons.net.ftp.FTPClient

for more info see the attached log.

Version-Release number of selected component (if applicable):
ER7-2

How reproducible:
always

Steps to Reproduce:
1. Deploy the attached project switchyard-example

Actual results:


Expected results:


Additional info:

Comment 1 Andrej Podhradsky 2013-12-18 12:06:20 UTC
Created attachment 838312 [details]
switchyard-example

Comment 2 Keith Babo 2013-12-18 13:54:52 UTC
This is a packaging issue that should be fixed in ER8.  See the comments on BZ 1044500 for details.

*** This bug has been marked as a duplicate of bug 1044500 ***


Note You need to log in before you can comment on or make changes to this bug.