Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1044494 - One cannot reset password for a Custom user once created
Summary: One cannot reset password for a Custom user once created
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: Nightly
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: Martin Bacovsky
QA Contact: Tazim Kolhar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-18 12:49 UTC by Tazim Kolhar
Modified: 2016-04-26 00:58 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-02 07:20:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
Reset Password (32.52 KB, image/png)
2013-12-18 12:49 UTC, Tazim Kolhar
no flags Details

Description Tazim Kolhar 2013-12-18 12:49:35 UTC
Created attachment 838320 [details]
Reset Password

Description of problem:

One cannot reset password for a Custom user once created 

Version-Release number of selected component (if applicable):
# rpm -qa | grep foreman
rubygem-hammer_cli_foreman-0.0.12-1.el6.noarch
foreman-compute-1.4.0-0.develop.201312161731git9e1b757.el6.noarch
foreman-installer-1.4.0-0.develop.201312171100git39bac59.el6.noarch
foreman-release-1.4.0-0.develop.201312161731git9e1b757.el6.noarch
foreman-1.4.0-0.develop.201312161731git9e1b757.el6.noarch
foreman-ovirt-1.4.0-0.develop.201312161731git9e1b757.el6.noarch
foreman-proxy-1.4.0-0.develop.201312091021git42bab91.el6.noarch
foreman-postgresql-1.4.0-0.develop.201312161731git9e1b757.el6.noarch
rubygem-foreman_api-0.1.8-1.el6.noarch
foreman-libvirt-1.4.0-0.develop.201312161731git9e1b757.el6.noarch
foreman-selinux-1.4.0-0.develop.201311220906gite342a0b.el6.noarch


How reproducible:
everytime

Steps to Reproduce:
1.Create a User
2.Try resetting the password coloumn
3.

Actual results:
Unable to reset the password

Expected results:
Functionality to reset password must be provided

Additional info:

Comment 1 RHEL Program Management 2013-12-18 12:56:04 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 2 Dominic Cleal 2013-12-18 12:57:43 UTC
Can you expand on why you're unable to reset the password?  As an admin user, I was able to type a new password into both the password + verify fields and it appeared to update the other account.  Your screenshot shows both password fields are on the edit page.

Comment 6 Tazim Kolhar 2015-09-02 07:20:27 UTC
Hi,

    Tried again to edit the existing User page for new password and also tried to create a new user .

   Was able to edit/update the password


# rpm -qa | grep foreman
ruby193-rubygem-foreman_discovery-2.0.0.19-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.20-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-proxy-1.7.2.5-1.el7sat.noarch
foreman-libvirt-1.7.2.35-1.el7sat.noarch
foreman-compute-1.7.2.35-1.el7sat.noarch
foreman-gce-1.7.2.35-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.3-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
dell-per805-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-debug-1.7.2.35-1.el7sat.noarch
foreman-ovirt-1.7.2.35-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
foreman-postgresql-1.7.2.35-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
foreman-vmware-1.7.2.35-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
foreman-1.7.2.35-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.5-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch
dell-per805-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-per805-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch

closing this as not a bug


Note You need to log in before you can comment on or make changes to this bug.