Bug 104451 - add compile-time join path verification for 2-way assocs
add compile-time join path verification for 2-way assocs
Status: CLOSED WONTFIX
Product: Red Hat Web Application Framework
Classification: Retired
Component: persistence (Show other bugs)
nightly
All Linux
medium Severity low
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks: 104452
  Show dependency treegraph
 
Reported: 2003-09-15 16:40 EDT by Vadim Nasardinov
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 14:29:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Nasardinov 2003-09-15 16:40:41 EDT
In plain English, when a two-way association is specified,
the join path for the first attribute is always the reverse
of the join path for the second attribute.  The PDL compiler
should flag an error, if an association block violates
this invariant (due to a stupid programming error).
Comment 1 Vadim Nasardinov 2005-08-03 14:29:46 EDT
stale

Note You need to log in before you can comment on or make changes to this bug.