Bug 104455 - checks for wrong NFS dir on diskless setup
checks for wrong NFS dir on diskless setup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-netboot (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-15 16:56 EDT by Tammy Fox
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-16 16:56:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2003-09-15 16:56:28 EDT
I installed Taroon on a system, and rsynced / to an NFS server. I setup NFS to
export /diskless/i386/RHEL-3-AS/root and tested it by mounting it with the mount
command. Then, I run r-c-netboot and get to the NFS information page. I enter
/diskless/i386/RHEL-3-AS/root, and it keeps saying I have to enter a directory
with a /boot directory even though I have one.

I finally got desparate and removed the /root from the directory name, and it
worked. This seems wrong since it doesn't have a boot/ subdirectory and since
the path without /root is not even NFS exported.
Comment 1 Daniel Walsh 2003-09-16 16:56:05 EDT
Fixed to allow the entry of either with or without /root/
 redhat-config-netboot-0.1.1-16

Dan

Note You need to log in before you can comment on or make changes to this bug.