Bug 104468 - autopartition falls over & advises it's probably a bug
autopartition falls over & advises it's probably a bug
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-15 18:34 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autopartion falls over reporting it's 'probably a bug' & to save and forward the dump (43.43 KB, text/plain)
2003-09-15 18:38 EDT, Need Real Name
no flags Details
requested fdisk -l dump (838 bytes, text/plain)
2003-09-24 13:47 EDT, Need Real Name
no flags Details
step-by-step thru Automatic Partitioning until the problem occurs (1.46 KB, text/plain)
2003-09-24 13:51 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-09-15 18:34:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030912

Description of problem:
on installing rh9 and optng for 'autopartition' the install falls over with an
advisory that it's probably a bug and to please save the dump and send it on in
 - also says it's (my words) an unexpected system error i.e. not allowed for in
the code's error handler - I've copied the dump into 'additonal information'
further on down - I tried re-running the install several times & then opting for
the 'autopartion' route but each time it fell over and it was always when I
tried to edit one of the partitions that it presented me with - upto what it
thought was the best config it was aok - the problem always occurred when I
tried to edit the config - in the end I got round the problem by re-running the
install and going down the 'disk druid' route - guess I was just being lazy
ininitally opting for 'autopartition' - rh9 then installed aok

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run install
2.opt for autopartition
3.edit one of the partitions it (autopartition) comes bsack with
4.install falls over
    

Actual Results:  through out the advisory saying it was 'probably' a bug asked
me to hit the presented 'save' button and to forward the dump to you - see
'additional information' for the dump

Expected Results:  I was trying to edit the partion size of one of the
partitions autopartion came back - which it let me do but when I then hit the
'ok' button it went belly up

Additional info:

your server says my report is too long - I'll try and get the dump to you as
anattachment as advised when I get your confirmation of bug receipt email
Comment 1 Need Real Name 2003-09-15 18:38:26 EDT
Created attachment 94517 [details]
autopartion falls over reporting it's 'probably a bug' & to save and forward the dump

both the file name and file content are as created by your dump process
Comment 2 Michael Fulbright 2003-09-23 11:38:02 EDT
Could you add to this report the original partition table (fdisk -l output is
fine) and then a list step-by-step of what you did in disk druid to cause this
failure. We are not able to reproduce it on our machines.
Comment 3 Need Real Name 2003-09-24 13:47:37 EDT
Created attachment 94685 [details]
requested fdisk -l dump

dump of fdisk -l as requested in your recent email
Comment 4 Need Real Name 2003-09-24 13:51:07 EDT
Created attachment 94686 [details]
step-by-step thru Automatic Partitioning until the problem occurs

step-by-step thru Automatic Partitioning until the problem occurs as requested
in your recent email
Comment 5 Jeremy Katz 2004-10-04 23:27:29 EDT
This looks like it should be better in our newer releases.

Note You need to log in before you can comment on or make changes to this bug.