Bug 1045358 - Rule name service is too heavy
Summary: Rule name service is too heavy
Keywords:
Status: CLOSED DUPLICATE of bug 1051463
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Toni Rikkola
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-20 09:16 UTC by Toni Rikkola
Modified: 2014-03-26 08:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-26 08:33:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Toni Rikkola 2013-12-20 09:16:55 UTC
Description of problem:
Currently, to show an up to date list of rules in the guided editors, we build the internal Data Model Oracle each time a file with rules is saved. This does get heavy if there are a lot of dependencies and/or the project is big.

Better way to do this, is improving the rule name service to notice changes in the files that generate DRL and parsing the rule names from the DRL. The rule name service needs to keep handles between the rule names and the paths the rule names were got from, so it is possible to rename, remove and move files and not break the existing rule name list.

Comment 3 Toni Rikkola 2014-03-26 08:33:00 UTC

*** This bug has been marked as a duplicate of bug 1051463 ***


Note You need to log in before you can comment on or make changes to this bug.