Bug 104549 - Missing BuildRequires elfutils-devel
Missing BuildRequires elfutils-devel
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: rpm (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On: 106321
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-16 20:51 EDT by Leonard den Ottolander
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 13:06:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build log for rpm (39.77 KB, text/plain)
2003-09-16 20:53 EDT, Leonard den Ottolander
no flags Details

  None (edit)
Description Leonard den Ottolander 2003-09-16 20:51:59 EDT
Description of problem:

Severn with many rawhide updates.

Building rpm-4.2.1-0.30 on my Athlon 800 fails. See attached build logs.

$ rpmbuild -ba rpm.spec 2>&1 | tee rpm.build.log
and
# rpmbuild --rebuild rpm-4.2.1-0.30.src.rpm 2>&1 | tee rpm.rebuild.log
both fail in the same way.
Comment 1 Leonard den Ottolander 2003-09-16 20:53:43 EDT
Created attachment 94542 [details]
Build log for rpm
Comment 2 Leonard den Ottolander 2003-09-16 21:53:00 EDT
The problem was just a missing elfutils-devel rpm. Built fine after
elfutils-devel was added.

You might want to add a BuildRequires elfutils-devel.
Comment 3 Jeff Johnson 2003-10-05 10:00:41 EDT
The buildrequires is needed, but cannot be added until
a decision is made with respect to releasing elfutils
packages for Red Hat 8.0 and 7.3. Otherwise rpm cannot
be released for those versions of RHL.
Comment 4 Jeff Johnson 2003-10-05 10:06:55 EDT
NEEDIFO pending dependency. WONTFIX if elfutils is not
released for 8.0 and 7.3.
Comment 5 Leonard den Ottolander 2004-03-10 08:48:30 EST
Since RHL 8.0 and RHL 7.3 are EOL maybe now is the time to add this
BuildRequires (for the upcoming FC2).
Comment 6 Jeff Johnson 2004-04-07 13:06:15 EDT
The build dependency has been there quite a while.

Note You need to log in before you can comment on or make changes to this bug.