Bug 1045544 - thrift-devel needs a dependency on boost-devel
Summary: thrift-devel needs a dependency on boost-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: thrift
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Will Benton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-20 17:11 UTC by Will Benton
Modified: 2014-02-14 08:00 UTC (History)
2 users (show)

Fixed In Version: thrift-0.9.1-10.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-11 23:12:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Will Benton 2013-12-20 17:11:20 UTC
Description of problem:

Thrift.h uses Boost headers but the thrift-devel package does not require boost-devel.

Version-Release number of selected component (if applicable):

thrift-0.9.1-9

How reproducible:

Install thrift-devel without boost-devel; attempt to compile a program using thrift.

Actual results:

Compilation will fail due to the absence of boost/utility/enable_if.hpp and boost/type_traits/is_convertible.hpp

Expected results:

Compilation will not fail for this reason and may even succeed.

Comment 1 Fedora Update System 2013-12-20 19:13:10 UTC
thrift-0.9.1-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/thrift-0.9.1-10.fc19

Comment 2 Fedora Update System 2013-12-20 19:14:14 UTC
thrift-0.9.1-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/thrift-0.9.1-10.fc20

Comment 3 Fedora Update System 2013-12-22 05:39:47 UTC
Package thrift-0.9.1-10.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing thrift-0.9.1-10.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23795/thrift-0.9.1-10.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-02-11 23:12:15 UTC
thrift-0.9.1-10.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2014-02-14 08:00:16 UTC
thrift-0.9.1-10.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.