Bug 104562 - gtkspell should require aspell, and -devel aspell-devel
Summary: gtkspell should require aspell, and -devel aspell-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: gtkspell (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
: 105944 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-17 08:45 UTC by Jens Petersen
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version: 2.0.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 20:41:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2003-09-17 08:45:09 UTC
Description of problem:
I suggest gtkspell.spec should require aspell as a dependency
and gtkspell-devel should require aspell-devel.

Version-Release number of selected component (if applicable):
gtkspell-2.0.4-1

Comment 1 Matt Wilson 2003-09-29 20:29:56 UTC
*** Bug 105944 has been marked as a duplicate of this bug. ***

Comment 2 Matt Wilson 2003-09-29 20:33:09 UTC
gtkspell has a DT_NEEDED on libaspell, I prefer those for package flexability if
the aspell ABI changes and we need to do a compat package.

Comment 3 Braden McDaniel 2003-09-29 21:05:01 UTC
I ran into this problem when trying to build gaim. Rebuilding the RPM failed
when it couldn't find the stuff in aspell-devel. gaim has a BuildReq on
gtkspell-devel, and suggested the problem was with the gtkspell-devel package's
dependencies.

It's my understanding the DT_NEEDED will not fix this problem. Is this problem
not worth fixing? If that's the case, what's the point of BuildReq?


Comment 4 Matt Wilson 2003-09-29 21:14:04 UTC
the comment was in regard to a Requires: aspell for the main gtkspell package. 
The Requires: aspell-devel requirement has been added to gtkspell-devel.



Note You need to log in before you can comment on or make changes to this bug.