Bug 1045669 - Extension does not support shell version
Summary: Extension does not support shell version
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-fedmsg
Version: 25
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-21 02:36 UTC by Andre Robatino
Modified: 2017-12-12 10:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 10:23:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Andre Robatino 2013-12-21 02:36:42 UTC
Description of problem:
This extension does not work in F20. gnome-tweak-tool shows the error "Extension does not support shell version", so it can't be enabled. This worked in F19.

Version-Release number of selected component (if applicable):
gnome-shell-extension-fedmsg-0.1.4-2.fc20.noarch

Comment 1 Luke Macken 2014-01-06 20:19:17 UTC
This is the error that is preventing the extension from loading on gnome-shell 3.10

(gnome-shell:5488): Gjs-WARNING **: JS ERROR: TypeError: PanelMenu.SystemStatusButton is undefined
@/usr/share/gnome-shell/extensions/fedmsg@lmacken-redhat.com/extension.js:45
initExtension@/usr/share/gnome-shell/js/ui/extensionSystem.js:217
loadExtension@/usr/share/gnome-shell/js/ui/extensionSystem.js:164
@/usr/share/gnome-shell/js/ui/extensionSystem.js:276
_emit@/usr/share/gjs-1.0/signals.js:124
ExtensionFinder<._loadExtension@/usr/share/gnome-shell/js/misc/extensionUtils.js:174
wrapper@/usr/share/gjs-1.0/lang.js:213
@/usr/share/gnome-shell/js/misc/fileUtils.js:50
onNextFileComplete@/usr/share/gnome-shell/js/misc/fileUtils.js:21

Comment 2 Grega Bremec 2014-01-09 11:06:46 UTC
I can witness to that. Same version.

At least for me, however, fedmsg will not start up on a "migrated" account, whereas on a freshly created F20-only account, fedmsg will still report it does not support shell version, but actually start and work.

Comment 4 Fedora Update System 2014-01-09 23:27:23 UTC
gnome-shell-extension-fedmsg-0.1.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.6-1.fc20

Comment 5 Fedora Update System 2014-01-11 08:38:04 UTC
Package gnome-shell-extension-fedmsg-0.1.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extension-fedmsg-0.1.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0614/gnome-shell-extension-fedmsg-0.1.6-1.fc20
then log in and leave karma (feedback).

Comment 6 Andre Robatino 2014-01-11 21:07:28 UTC
The bodhi update fixes the problem in F20. However, it's still broken in Rawhide. (Sorry I didn't test that earlier.)

gnome-shell-3.11.3-1.fc21.x86_64
fedmsg-0.7.2-1.fc21.noarch
fedmsg-notify-0.5.4-1.fc21.noarch
gnome-shell-extension-fedmsg-0.1.6-1.fc21.noarch

Comment 7 Grega Bremec 2014-01-15 15:53:57 UTC
Confirming that the update fixes fedmsg in F20.

Comment 8 Luke Macken 2014-01-15 17:41:33 UTC
Thank you for the confirmation folks! As for rawhide, I just started building 0.1.6.1 in koji, so hopefully it'll be working tomorrow :)

Comment 9 Andre Robatino 2014-01-17 02:26:09 UTC
Still broken in Rawhide.

gnome-shell-3.11.3-2.fc21.x86_64
fedmsg-0.7.4-1.fc21.noarch
fedmsg-notify-0.5.4-1.fc21.noarch
gnome-shell-extension-fedmsg-0.1.6.1-1.fc21.noarch

Comment 10 Fedora Update System 2014-01-19 04:08:51 UTC
gnome-shell-extension-fedmsg-0.1.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Andre Robatino 2014-01-19 04:10:33 UTC
Reopening since Rawhide is still broken.

Comment 12 Luke Macken 2014-01-25 01:38:00 UTC
Simply changing the version to 3.11.3 in the metadata.json yields this error. More investigation needed.

(gnome-shell:24894): Gjs-WARNING **: JS ERROR: Exception in callback for signal: extension-found: SyntaxError: syntax error
initExtension@resource:///org/gnome/shell/ui/extensionSystem.js:217
loadExtension@resource:///org/gnome/shell/ui/extensionSystem.js:164
@resource:///org/gnome/shell/ui/extensionSystem.js:276
_emit@/usr/share/gjs-1.0/signals.js:124
ExtensionFinder<._loadExtension@resource:///org/gnome/shell/misc/extensionUtils.js:174
wrapper@/usr/share/gjs-1.0/lang.js:213
@/usr/share/gjs-1.0/lang.js:112
collectFromDatadirs@resource:///org/gnome/shell/misc/fileUtils.js:47
ExtensionFinder<.scanExtensions@resource:///org/gnome/shell/misc/extensionUtils.js:179
wrapper@/usr/share/gjs-1.0/lang.js:213
_loadExtensions@resource:///org/gnome/shell/ui/extensionSystem.js:278
enableAllExtensions@resource:///org/gnome/shell/ui/extensionSystem.js:286
_sessionUpdated@resource:///org/gnome/shell/ui/extensionSystem.js:317
init@resource:///org/gnome/shell/ui/extensionSystem.js:325
_initializeUI@resource:///org/gnome/shell/ui/main.js:204
start@resource:///org/gnome/shell/ui/main.js:117
@<main>:1

Comment 13 Andre Robatino 2014-04-09 18:41:23 UTC
This appears fixed with gnome-shell-extension-fedmsg-0.1.7-1.fc21.noarch. So, what was wrong before? Does it have anything to do with GNOME being a development (3.11) version before?

Comment 14 Luke Macken 2014-04-09 19:05:20 UTC
(In reply to Andre Robatino from comment #13)
> This appears fixed with gnome-shell-extension-fedmsg-0.1.7-1.fc21.noarch.
> So, what was wrong before? Does it have anything to do with GNOME being a
> development (3.11) version before?

Yup, it should work with gnome-shell 3.12.0

I had to make some tweaks to the dbus interface definition to get it working:

https://github.com/lmacken/gnome-shell-extension-fedmsg/commit/66b8a7b84244a960dfa83c1999edd946b789f57e

Comment 15 Andre Robatino 2014-05-07 12:28:15 UTC
I'm seeing this again with latest updates.

gnome-shell-extension-fedmsg-0.1.7-1.fc21.noarch
gnome-shell-3.13.1-2.fc21.x86_64

Comment 16 Luke Macken 2014-05-07 16:46:53 UTC
I spun up 0.1.8 and built in in rawhide. Thanks!

Comment 17 Andre Robatino 2014-06-05 21:47:38 UTC
Am seeing this again.

gnome-shell-extension-fedmsg-0.1.8-1.fc21.noarch
gnome-shell-3.13.2-1.fc21.x86_64

Comment 18 Andre Robatino 2014-09-27 17:37:02 UTC
Still broken in both F21 and Rawhide.

gnome-shell-extension-fedmsg-0.1.8-2.fc21.noarch
gnome-shell-3.14.0-2.fc21.x86_64

Comment 19 Andre Robatino 2014-12-14 10:39:20 UTC
See https://lists.fedoraproject.org/pipermail/users/2014-December/456221.html - I was able to make it work by editing metadata.json to include the shell version 3.14. Please update the package accordingly. Thanks.

Comment 20 Andre Robatino 2014-12-16 12:53:37 UTC
Still broken in gnome-shell-extension-fedmsg-0.1.9-1.fc22.noarch (and I did restart gnome shell). I see you added "3.14" to metadata.json so I have no idea why it doesn't work, since it did when I did nothing other than edit that file. At some point you also might want to clean out the old development versions "3.11", "3.13.1" and "3.13".

Comment 21 Andre Robatino 2014-12-16 14:09:01 UTC
My mistake. I had gotten it working in F21 by adding "3.14" in metadata.json. In Rawhide, I had just disabled extension version validation. Rawhide currently has gnome-shell-3.15.2-1.fc22, and I was only able to get it working in Rawhide by adding "3.15.2" in metadata.json ("3.15" did not work). I understand it's a pain to keep updating the exact gnome version in metadata.json when gnome-shell is in a devel version, so maybe it's best to just include stable gnome shell versions. I don't know if there's a policy for that, but personally I can just disable the version checking when gnome shell is in a devel version. Presumably adding "3.14" should work fine for F21. Please also clean out the old devel versions "3.11", "3.13", "3.13.1". Thanks.

Comment 22 Fedora Update System 2014-12-17 18:50:36 UTC
gnome-shell-extension-fedmsg-0.1.9-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.9-1.fc21

Comment 23 Fedora Update System 2014-12-19 18:32:45 UTC
Package gnome-shell-extension-fedmsg-0.1.9-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extension-fedmsg-0.1.9-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-17298/gnome-shell-extension-fedmsg-0.1.9-1.fc21
then log in and leave karma (feedback).

Comment 24 Fedora Update System 2014-12-21 06:39:48 UTC
gnome-shell-extension-fedmsg-0.1.9-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Luke Macken 2015-01-29 18:08:14 UTC
gnome-shell-extension-fedmsg-0.1.9-2.fc22 built in rawhide.
http://koji.fedoraproject.org/koji/taskinfo?taskID=8772041

I added a patch to the Fedora repo that will make it easy to update the metadata.json in the future, so I won't need to do upstream releases for each version bump.

Comment 26 Andre Robatino 2015-01-30 03:11:08 UTC
When is it expected to start working? It's not working at the moment, after having updated to the new version and restarted gnome shell, and I still see the list of obsolete versions "3.10", "3.11", "3.12", "3.13.1", "3.13", 3.14", "3.15" in metadata.json.

Comment 27 Luke Macken 2015-01-30 19:08:40 UTC
Hmm, if you edit the file by hand and add 3.15.4 does it work?

Comment 28 Andre Robatino 2015-01-31 02:02:37 UTC
Yes, it works if I add 3.15.4 manually. I'll wait for it to start working automatically and close the bug again when that happens.

Comment 29 Andre Robatino 2015-02-01 10:32:02 UTC
Working with gnome-shell-extension-fedmsg-0.1.9-3.fc22.noarch.

Comment 30 Andre Robatino 2015-02-28 17:18:19 UTC
Broken again.

gnome-shell-extension-fedmsg-0.1.9-3.fc22.noarch
gnome-shell-3.15.90-1.fc23.x86_64

Comment 31 Luke Macken 2015-03-01 20:51:51 UTC
Fixed in rawhide (hopefully). Thanks! http://koji.fedoraproject.org/koji/taskinfo?taskID=9110428

Comment 32 Andre Robatino 2015-03-02 10:09:43 UTC
Confirmed fixed, thanks.

Comment 33 Andre Robatino 2015-03-06 10:28:35 UTC
Broken again and today's 20150306 updates did not fix it. (All the extensions were broken yesterday with the same error. After today's updates and restarting gnome-shell, the other extensions were fixed but this one is still broken.)

gnome-shell-extension-fedmsg-0.1.9-4.fc23.noarch
gnome-shell-3.15.91-1.fc23.x86_64

Comment 34 Luke Macken 2015-03-06 16:32:35 UTC
Building in rawhide now. Thanks.
http://koji.fedoraproject.org/koji/taskinfo?taskID=9157420

Comment 35 Andre Robatino 2015-03-07 07:05:20 UTC
It's fixed in rawhide, but the problem exists in F22. Can you do a build for that?

gnome-shell-3.15.90-1.fc22.x86_64
gnome-shell-extension-fedmsg-0.1.9-3.fc22.noarch

Comment 36 Fedora Update System 2015-03-09 04:59:46 UTC
gnome-shell-extension-fedmsg-0.1.9-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.9-5.fc22

Comment 37 Fedora Update System 2015-03-18 10:33:00 UTC
gnome-shell-extension-fedmsg-0.1.9-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 38 Andre Robatino 2015-03-18 11:12:29 UTC
Broken in Rawhide.

gnome-shell-3.15.92-2.fc23.x86_64
gnome-shell-extension-fedmsg-0.1.9-5.fc23.noarch

Comment 39 Andre Robatino 2015-03-19 19:35:40 UTC
Now broken in F22 as well.

gnome-shell-3.15.92-2.fc22.x86_64
gnome-shell-extension-fedmsg-0.1.9-5.fc22.noarch

Comment 40 Fedora Update System 2015-03-19 23:01:01 UTC
gnome-shell-extension-fedmsg-0.1.9-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.9-6.fc22

Comment 41 Andre Robatino 2015-03-20 10:34:55 UTC
Fixed in Rawhide, thanks. Will test and give karma in F22 when it hits updates-testing.

Comment 42 Andre Robatino 2015-03-24 14:29:36 UTC
Broken in Rawhide.

gnome-shell-3.16.0-1.fc23.x86_64
gnome-shell-extension-fedmsg-0.1.9-6.fc23.noarch

Comment 43 Fedora Update System 2015-03-26 22:05:30 UTC
gnome-shell-extension-fedmsg-0.1.9-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 44 Fedora Update System 2015-03-26 23:25:41 UTC
gnome-shell-extension-fedmsg-0.1.9-7.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.9-7.fc22

Comment 45 Andre Robatino 2015-03-26 23:37:05 UTC
Broken in F22 as well.

gnome-shell-3.16.0-1.fc22.x86_64
gnome-shell-extension-fedmsg-0.1.9-6.fc22.noarch

Comment 46 Andre Robatino 2015-03-26 23:53:12 UTC
Ignore my last comment - thanks for the quick update.

Comment 47 Fedora Update System 2015-03-31 21:47:48 UTC
gnome-shell-extension-fedmsg-0.1.9-7.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 48 Andre Robatino 2015-04-15 17:43:29 UTC
Broken in Rawhide.

gnome-shell-3.16.1-1.fc23.x86_64
gnome-shell-extension-fedmsg-0.1.9-7.fc23.noarch

Comment 49 Andre Robatino 2015-04-17 19:30:46 UTC
Also broken in F22.

gnome-shell-3.16.1-1.fc22.x86_64
gnome-shell-extension-fedmsg-0.1.9-7.fc22.noarch

Comment 50 Fedora Update System 2015-05-06 01:13:52 UTC
gnome-shell-extension-fedmsg-0.1.9-8.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.9-8.fc22

Comment 51 Andre Robatino 2015-05-06 16:11:08 UTC
Still broken in Rawhide.

gnome-shell-3.17.1-1.fc23.x86_64
gnome-shell-extension-fedmsg-0.1.9-8.fc23.noarch

I will test and give karma for the F22 version when it hits updates-testing.

Comment 52 Andre Robatino 2015-05-08 15:38:08 UTC
Fixed in Rawhide.

gnome-shell-3.17.1-1.fc23.x86_64
gnome-shell-extension-fedmsg-0.1.9-9.fc23.noarch

Comment 53 Andre Robatino 2015-05-16 12:26:02 UTC
Just broke in F22 since gnome-shell 3.16.2 was pushed to updates-testing.

gnome-shell-3.16.2-1.fc22.x86_64
gnome-shell-extension-fedmsg-0.1.9-8.fc22.noarch

Comment 54 Andre Robatino 2015-05-16 13:43:59 UTC
Checked that if I clean up the metadata.json entry as follows,  making use of kalev's comment in https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.9-8.fc22

{"shell-version": ["3.10", "3.12", "3.14", "3.16", "3.17.1"],

with at most one unstable version appearing only at the end (since there's no point in keeping old unstable versions, since nothing uses them), and use the micro version only for that version, this file could be used for both the branched/stable and Rawhide builds, and would be much easier to maintain.

Comment 55 Andre Robatino 2015-05-16 13:55:06 UTC
Also, I believe that of the stable/branched Fedora releases, F20 uses 3.10, F21 uses 3.14, F22 uses 3.16. So you could remove "3.12" from metadata.json right now and get rid of old stable gnome-shell versions as the corresponding Fedora versions go EOL.

Comment 56 Luke Macken 2015-05-20 19:25:42 UTC
(In reply to Andre Robatino from comment #54)
> Checked that if I clean up the metadata.json entry as follows,  making use
> of kalev's comment in
> https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.9-8.
> fc22
> 
> {"shell-version": ["3.10", "3.12", "3.14", "3.16", "3.17.1"],
> 
> with at most one unstable version appearing only at the end (since there's
> no point in keeping old unstable versions, since nothing uses them), and use
> the micro version only for that version, this file could be used for both
> the branched/stable and Rawhide builds, and would be much easier to maintain.

Excellent, thanks for figuring this out. Updating the metadata patch now.

Comment 57 Andre Robatino 2015-05-20 19:34:29 UTC
Looking at other standard extensions such as alternate tab and background logo, for F20 and Rawhide, the metadata.json for each only includes the one shell version for that release. Since I've never done packaging I don't know which way is easier.

Comment 58 Fedora Update System 2015-05-20 19:36:26 UTC
gnome-shell-extension-fedmsg-0.1.9-10.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-shell-extension-fedmsg-0.1.9-10.fc22

Comment 59 Andre Robatino 2015-05-21 01:47:56 UTC
Fixed in F22 with gnome-shell-extension-fedmsg-0.1.9-10.fc22 (and should never need another update for F22). Karma left.

Comment 60 Fedora Update System 2015-05-26 03:18:51 UTC
gnome-shell-extension-fedmsg-0.1.9-8.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 61 Fedora Update System 2015-05-27 16:25:31 UTC
gnome-shell-extension-fedmsg-0.1.9-10.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 62 Andre Robatino 2015-05-29 17:31:23 UTC
Broken in Rawhide.

gnome-shell-3.17.2-1.fc23.x86_64
gnome-shell-extension-fedmsg-0.1.9-10.fc23.noarch

Comment 63 Andre Robatino 2015-07-03 16:18:28 UTC
Please update the Rawhide build for gnome-shell-3.17.3. Thanks.

Comment 64 Andre Robatino 2015-07-10 14:22:27 UTC
Fixed with gnome-shell-extension-fedmsg-0.1.9-13.fc23.noarch. Thanks.

Comment 65 Andre Robatino 2015-07-24 15:11:24 UTC
Please update Rawhide and F23 for gnome-shell-3.17.4. Thanks.

Comment 66 Luke Macken 2015-07-24 18:01:22 UTC
Rebuilt for gnome-shell 3.17.4. Thanks!

Comment 67 Andre Robatino 2015-08-22 23:06:30 UTC
Please update Rawhide and F23 for gnome-shell-3.17.90. Thanks.

Comment 68 Luke Macken 2015-08-23 02:14:20 UTC
Rebuilt. Thanks for the report.

Comment 69 Andre Robatino 2015-08-25 03:54:20 UTC
I see a build for F32 but not for Rawhide.

Comment 70 Andre Robatino 2015-09-24 06:05:54 UTC
Both F23 and Rawhide are now on GNOME Shell 3.18. Please do builds for each of these (which will be good until 3.19.x comes out). Thanks.

Comment 71 Jan Kurik 2016-02-24 15:30:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 72 Andre Robatino 2016-03-24 19:31:38 UTC
Changed the Version back to Rawhide, and filed https://bugzilla.redhat.com/show_bug.cgi?id=1321151 for F24.

Comment 73 Jan Kurik 2016-07-26 04:36:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 75 Andre Robatino 2016-10-20 18:56:04 UTC
I'm not sure if this needs to be considered a bug in F25 and Rawhide anymore since gnome-shell version checking is now disabled by default. But it would still be nice if it could be fixed in F23 ( https://bugzilla.redhat.com/show_bug.cgi?id=1268500 ) and F24 ( https://bugzilla.redhat.com/show_bug.cgi?id=1321151 ) before F23 goes EOL in about 2 months.

Comment 76 Fedora End Of Life 2017-11-16 19:50:22 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 77 Fedora End Of Life 2017-12-12 10:23:21 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.