Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1045747 - PackageKit cannot detect or install software collections
Summary: PackageKit cannot detect or install software collections
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-21 17:52 UTC by Michael Catanzaro
Modified: 2015-06-29 13:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 13:41:40 UTC
Type: Bug


Attachments (Terms of Use)
sudo /usr/libexec/packagekitd --verbose (112.03 KB, text/plain)
2013-12-21 17:52 UTC, Michael Catanzaro
no flags Details

Description Michael Catanzaro 2013-12-21 17:52:04 UTC
Created attachment 840080 [details]
sudo /usr/libexec/packagekitd --verbose

Description of problem: PackageKit cannot install software collections in Fedora 20. This was also broken in Fedora 18, but it worked fine in Fedora 19. When running packagekitd --verbose, I see the following warning:

"11:37:42	PackageKit-Yum      failed to load /etc/yum.repos.d/packagekit-media.repo: No such file or directory"


Version-Release number of selected component (if applicable):  PackageKit-yum 0.8.13-1.fc20


How reproducible: Always


Steps to Reproduce:
1. Install F20 Live Desktop
2. Use gnome-software to install gpk-application
3. Attempt to use gpk-application to install a software collection

Actual results: I got different results when attempting this. First (a) gpk-application pretends to install the software in <1s. The software is listed as installed in the Software Log. Restarting gpk-application reveals that none of the software was actually installed. A second attempt led to the same result, but further attempts led to (b) the Apply Changes button in gpk-application disappears, rendering the application useless. I believe the log I have attached corresponds to case (b).


Expected results: The software is installed


Additional info: Installing individual packages works fine - it's only software collections that are broken.

Comment 1 Michael Catanzaro 2013-12-21 18:12:14 UTC
Additionally, PackageKit is unable to detect software collections installed manually with 'yum groupinstall' and displays all collections as uninstalled.

Comment 2 Fedora End Of Life 2015-05-29 10:05:44 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Fedora End Of Life 2015-06-29 13:41:40 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.