Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1046035 - "Can not open file -" error when connecting with client side printing support
Summary: "Can not open file -" error when connecting with client side printing support
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: x2goclient
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-23 10:26 UTC by Ville Skyttä
Modified: 2014-07-07 21:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-07 21:19:30 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of displayed error dialog (7.11 KB, image/png)
2013-12-23 10:26 UTC, Ville Skyttä
no flags Details

Description Ville Skyttä 2013-12-23 10:26:25 UTC
Created attachment 840744 [details]
Screenshot of displayed error dialog

Client: F-19 x2goclient-4.0.1.2-1.fc19.x86_64
Server: F-19 x2goserver-4.0.1.9-2.fc19.x86_64
Session: MATE

When connecting with client side printing support enabled in config, I get a dialog saying "Connection failed Can not open file -" upon connecting; it doesn't occur when client side printing support is unchecked. Contrary to what the dialog says, connection is established and seems to work fine -- I haven't tried anything printing related though.

Comment 1 Ville Skyttä 2013-12-23 10:27:46 UTC
Forgot to note that I already tried to set loglevel=debug in x2goserver.conf and looked into client's details as well as what it outputs on the console but didn't see anything related.

Comment 2 Orion Poplawski 2014-06-26 22:36:06 UTC
Can you still reproduce this?

Comment 3 Ville Skyttä 2014-07-04 15:56:51 UTC
Nope, not with this setup:

Client: F-20 x2goclient-4.0.2.0-1.fc20.x86_64
Server: F-20 x2goserver-4.0.1.15-1.fc20.x86_64
Session: MATE

As far as I'm concerned this bug can be closed.

Comment 4 Ville Skyttä 2014-07-04 15:58:01 UTC
Another difference to the setup I initially got the error with is that the current one is using a proxied SSH connection, but I suppose that doesn't affect client side printing in any way.


Note You need to log in before you can comment on or make changes to this bug.