Bug 104627 - openssh-3.1p1-14 depends on __func__ which on RedHat 6.2 does not exist in the ettera packages
openssh-3.1p1-14 depends on __func__ which on RedHat 6.2 does not exist in th...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-17 23:16 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 10:46:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-09-17 23:16:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030708

Description of problem:
the problem is that openssh-3.1p1-14 will not build on a RedHat 6.2:
auth2-pam.c: In function `input_userauth_info_response_pam':
auth2-pam.c:146: `__func__' undeclared (first use in this function)
auth2-pam.c:146: (Each undeclared identifier is reported only once
auth2-pam.c:146: for each function it appears in.)
make: *** [auth2-pam.o] Error 1

__func__ is not present in egcs-1.1.2-30

workaround::::
cd /usr/src/redhat/SOURCES
sed -e's/__func__/__FUNCTION__/' < openssh-adv.iss.patch > openssh-adv.iss-62.patch

then patch openssh.spec

--- openssh.spec        Wed Sep 17 23:07:14 2003 original
+++ openssh.spec        Wed Sep 17 23:07:55 2003
@@ -68,7 +68,11 @@
 Patch1: openssh-2.3.0p1-path.patch
 Patch2: openssh-2.9p1-groups.patch
 Patch3: openssh-3.1p1-defaultkeys.patch
+%if %{build6x}
 Patch4: openssh-adv.iss-62.patch
+%else
+Patch4: openssh-adv.iss.patch
+%endif
 Patch5: openssh-3.1p1-pam-timing.patch
 Patch6: openssh-3.1p1-buffer-size.patch
 Patch7: openssh-3.1p1-skip-initial.patch


Version-Release number of selected component (if applicable):
openssh-3.1p1-14

How reproducible:
Always

Steps to Reproduce:
rpm --rebuild --define 'build6x 1' openssh-3.1p1-14.src.rpm

Actual Results:  the problem is that openssh-3.1p1-14 will not build on a RedHat
6.2:
auth2-pam.c: In function `input_userauth_info_response_pam':
auth2-pam.c:146: `__func__' undeclared (first use in this function)
auth2-pam.c:146: (Each undeclared identifier is reported only once
auth2-pam.c:146: for each function it appears in.)
make: *** [auth2-pam.o] Error 1


Expected Results:  normal build

Additional info:
Comment 1 Tomas Mraz 2005-02-04 10:46:25 EST
This is not supported.

Note You need to log in before you can comment on or make changes to this bug.