Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1046277 - Nouveau driver prevents system reboot
Summary: Nouveau driver prevents system reboot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-24 10:22 UTC by Nrbrtx
Modified: 2014-01-09 06:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-09 06:11:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Nrbrtx 2013-12-24 10:22:15 UTC
Description of problem:
I have Sony VAIO F13Z1R with Nvidia GT425M.

lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 425M] (rev a1)

I installed Fedora 20 on my laptop. I have only nouveau driver.


Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-1.0.9-2.fc20.i686

Steps to Reproduce:
1. Boot system
2. Do some work
3. Reboot system (Fedora will exit, GRUB will be shown)

Actual results:
I see many identical lines on console with text
[ time.TTTTTT ] nouveau W [    PFIFO][0000:01:00.0] INTR 0x01000000: 0x00000005
and these messages prevent system reboot.

Expected results:
Fedora will exit, system rebooted, GRUB is shown.

Comment 1 Ben Skeggs 2014-01-06 23:42:45 UTC
Hmm, I thought I accidentally fixed this issue a while back while looking at something else.

What kernel are you running with here?

Comment 2 Nrbrtx 2014-01-07 15:41:16 UTC
Hello, Ben! Thank you for reply.

I'm on Fedora 20.

I get these error messages on kernel-PAE-3.11.9-300.fc20.i686 and 
kernel-PAE-3.12.5-302.fc20.i686. Sometimes the aforementioned messages prevent reboot, sometimes system reboots normally after some amount of these messages.

Recent yum upgrade updated kernel to kernel-PAE-3.12.6-300.fc20.i686 (nouveau version is the same). 
Now my system reboots quickly without aforementioned messages.

Comment 3 Ben Skeggs 2014-01-07 22:06:45 UTC
The relevant bits of nouveau for this issue are in the kernel, so that makes sense :)  I'm reading correctly that the issue is now resolved then?

Thanks.

Comment 4 Nrbrtx 2014-01-08 18:05:10 UTC
Yes, bug is resolved with new kernel.
Thank you!


Note You need to log in before you can comment on or make changes to this bug.