Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1046311 - [RFE] [engine-webadmin] Run-once VM should include 'open console automatically' check-box
Summary: [RFE] [engine-webadmin] Run-once VM should include 'open console automaticall...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.3.0
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Scott Herold
QA Contact: Shai Revivo
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-24 12:50 UTC by Elad
Modified: 2015-11-12 15:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-12 15:13:42 UTC
oVirt Team: ---
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)
screenshot (33.20 KB, image/png)
2013-12-24 12:50 UTC, Elad
no flags Details

Description Elad 2013-12-24 12:50:02 UTC
Created attachment 841247 [details]
screenshot

Description of problem:
My proposal is to add a check-box to 'run-once' window which will allow user to open a console window automatically, immediately after staring the VM.

In my opinion, this feature will be very helpful to user because when installing an operating system from PXE, user has only few seconds to catch the PXE menu. During this few seconds user should be manage to open the console window manually. 

The check-box can be added to the 'display protocol' tab in the 'run-once' window.


Additional info: screenshot

Comment 1 Itamar Heim 2013-12-29 09:01:03 UTC
that's an inherit race condition by design. run once ends when the VM is in waitforlaunch state in vdsm. opening a console at this point will fail as no qemu process listening yet.

Comment 3 Michal Skrivanek 2015-03-27 08:04:49 UTC
note there is the Start in Paused mode

Comment 4 Yaniv Kaul 2015-11-12 12:43:53 UTC
I think it's a fine RFE, but due to the issue in comment 1 , we'll probably not going to invest in implementing it.

I do wish we could launch a VM much faster than we do today, btw.

Michal - unless you think differently, I assume we can CLOSE-WONTFIX.

Comment 5 Michal Skrivanek 2015-11-12 15:13:42 UTC
we do launch VMs quite fast, the trouble is with UI refresh. We eliminated the delay on engine-vdsm polling (up to 3s) so it should be better in 3.6, still the up to 5s UI refresh remains

closing based on partial improvement in launch time and workaround/suggestion in comment #3


Note You need to log in before you can comment on or make changes to this bug.