Bug 104650 - missing user may lead to a broken header
missing user may lead to a broken header
Status: CLOSED DUPLICATE of bug 97727
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-09-18 09:50 EDT by Michael Schröder
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:58:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Schröder 2003-09-18 09:50:36 EDT
If a user cannot be found in the passwd and rpm turns of an s-bit
a broken header will be written to the packages database (bad header
SHA1 digest). The code in question contains a nice "XXX this diddles header
memory" comment (line 1717 psm.c).
Comment 1 Jeff Johnson 2003-09-19 08:31:14 EDT

*** This bug has been marked as a duplicate of 97727 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.