Bug 104674 - logrotate broke because of popt (news at 11)
Summary: logrotate broke because of popt (news at 11)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: logrotate   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-18 19:14 UTC by Stephen John Smoogen
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-19 17:01:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen John Smoogen 2003-09-18 19:14:37 UTC
Description of problem:

logrotate no longer runs with 2003/09/17 updates due to following error:

/etc/cron.daily/logrotate:

/usr/sbin/logrotate: Symbol `poptHelpOptions' has different size in shared
object, consider re-linking

relinking does not help. Can not file against popt because there is no RHEL
entry for the popt package.

[root@smoogen1 smoogen]# rpm -q logrotate popt
logrotate-3.6.9-1
popt-1.8.1-1

Comment 1 Bill Nottingham 2003-09-18 21:07:30 UTC
I believe this is fixed in popt-1.8.1-3

Comment 2 Mickey Stein 2003-12-19 01:13:41 UTC
#1 -- possibly, but It also vanishes if you make the rpm's in question
from .src.rpm's. I had it with kudzu as well as rhgb and some others,
and remade them from source which also worked. Of course, I hope
that's true about 1.8.1.3.




Note You need to log in before you can comment on or make changes to this bug.