Bug 104680 - HP CCISS Controller performing very poorly
HP CCISS Controller performing very poorly
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-18 16:43 EDT by Todd McCullough
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd McCullough 2003-09-18 16:43:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
We have a dl 360 g3 with a default install of RH8.0. We've downloaded the 
latest Proliant linux driver from HP for the 5i series controller and installed 
it. This brought our cciss driver from 2.4.30 too 2.4.46. But under a simple 
test performed worse then a celeron 1.4 PC.

In our test we measured IO by reading and writing an 8k file in a while loop. 
We did this to simulate a stressed database enviroment

[root@host-116 root]# dd if=/dev/zero of=/tmp/test bs=1024 count=8
                     while [ /bin/true ] ; 
                          do cat /tmp/test > /tmp/test2 ;sync ;
                     done &

After looking at iostat we noticed it was only writing 1.4 megs a second to 
disk. When any other computer could write from 7.9 to 10 megs a second.

                      iostat -x /dev/cciss/c0d0p6  -t 30





Version-Release number of selected component (if applicable):
kernel-2.4.18-14 

How reproducible:
Always

Steps to Reproduce:
1.[root@host-116 root]# dd if=/dev/zero of=/tmp/test bs=1024 count=8

2.while [ /bin/true ] ; do cat /tmp/test > /tmp/test2 ;sync ;done &

3. iostat -x /dev/cciss/c0d0p6  -t 30
    

Actual Results:  SLOW 

Expected Results:  SHOULD BE FAST

Additional info:
Comment 1 Dave Jones 2003-09-19 06:54:11 EDT
If you've found a problem with a third party driver, tell them about it.
This isn't something we shipped, so we won't be putting out an updated kernel
any time soon fixing this.
Comment 2 Todd McCullough 2003-09-19 09:34:59 EDT
We only used the third party driver when the stock redhat install didn't perform
as expected. It was suggested by Red Hat technical support.

Currently we've tried this test on RH7.2 7.3 8.0 9.0. 

None of them have worked with this machine.

I've tried this test with Dell servers and clones using the above O/S's and
there are were no problems. How can you say that this isn't your problem when it
works on every other platform except the one you've certified.

Redhat uses the dl 360 g3/g2 for all it's bench mark tests in advance server. 

So unless I go spend some money I can't see whether it's fixed. I wrote the bug
so it could be confirmed or not. 

If it does work in Advance server, then why?


Basically this is the situation.  Install Red Hat 8 out of the box onto a DL360
G3 and it performs slowly.  Barely over 1M/s of sustained writing (The only
thing the "3rd party" driver did was increase performance to 1.4M/s).  Configure
the array to be Raid 0 and it doubles the performance to just over 2M/s of
sustained writing.

A cheap clone with ATA100 with the same RH8 install doing the same test will get
about 10M/s of sustained writing.

Clearly the certified platform of RH8 and a DL360 G3 is having issues that to no
one in support has been able to explain or help with.  Red Hat support told me
to open this bug in the first place.
Comment 3 Arjan van de Ven 2003-09-19 10:01:55 EDT
I'm sure RH support also asked you to try the latest erratum kernel ?
Comment 4 Todd McCullough 2003-09-19 11:11:26 EDT
I'm using the below.

RH8.0 2.4.20-20.8
CISS driver 2.4.42


RH9.0  2.4.20-19.9smp 
CISS driver 2.4.42

Comment 5 goldorak91 2004-06-07 10:06:03 EDT
poor performances ...

I'm using a 2.4.24 kernel with a 2.4.50 driver and I encounter the
same pbs with a 5i/532 raid card in raid 0+1

When copying larger files (100Mb) the performances are best but like
an old ide drive (about 35 MB/s) !

is there any solution to this ???
Comment 6 Todd McCullough 2004-06-07 10:26:33 EDT
You need the on-board battery cache for the raid controller installed.  

Part# 25514-b21
Comment 7 Bugzilla owner 2004-09-30 11:41:32 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.