Bug 10471 - autofs does not understand yp:foo in auto.master file
Summary: autofs does not understand yp:foo in auto.master file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-31 07:32 UTC by christian.bac
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-05 20:02:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description christian.bac 2000-03-31 07:32:02 UTC
autofs script consider that names in /etc/auto.master are only file names.
It does not split the names that look like foo:bar (yp, nis, ...).

diff -e autofs.old autofs from my correction.

99,100c
                    map=`echo "/etc/$map" | sed -e 's:^/etc//:/:'`
                    if [ -x $map ]; then
                        echo "$DAEMON $mountoptions $dir program $map
$options $
localoptions"
                    elif [ -f $map ]; then
                        echo "$DAEMON $mountoptions $dir file $map $options
$loc
aloptions"
                    else
                        echo "$DAEMON $mountoptions $dir `basename $map`
$option
s $localoptions"
                    fi
                fi
.
94,97c
                echo $map |grep ':' >/dev/null
                if [ $? ]; then
                        map=`echo $map| sed 's/:/ /g'`
                        echo "$DAEMON $mountoptions $dir $map $options
$localopt
ions"
.
85d

Comment 1 Nalin Dahyabhai 2000-04-05 20:02:59 UTC
This will be fixed in autofs-3.1.4-6 in Raw Hide
(ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/),
which fixes these assumptions and simplifies a few
other things a bit.

Please reopen this bug ID if you find that upgrading
doesn't solve the problem.

Comment 2 das_deniz 2000-04-07 14:00:59 UTC
maybe this would be resolved if there was an autofs-3.1.4-6 in RawHide

but there is none... only -5 (as of Apr 7)

Comment 3 Nalin Dahyabhai 2000-04-07 14:45:59 UTC
Until Raw Hide gets an update, the same test packages will also be available at
http://people.redhat.com/nalin/test/.

Comment 4 j.pelan 2000-06-15 14:56:18 UTC
Why hasn't this package been added to the 6.2 errata ?
autofs-3.1.4-4 is clearly broken.

Comment 5 Need Real Name 2000-08-21 15:56:20 UTC
Despite the comments above, there also is no autofs-3.1.4-6 in
http://people.redhat.com/nalin/test/.   Additionally, the autofs script does not
look at /etc/nsswitch.conf, despite the fact that there is an entry for it in
the distributed /etc/nsswitch.conf file. Looks like someone was thinking about
it... :)

As of autofs-3.1.4-4, the
no-I'm-not-gonna-look-at-NIS-if-you-have-a-local-/etc/auto.master bug is not
fixed, so I'm fixing both of these problems and I'm going to submit my fixes to
you guys.

I have to say, COME ON GUYS!  This has been broken for over a year (since the
release of RedHat 6.1 anyway), and it's only a 300 line shell script.  Between
this and breaking sort -n (the source for which comes complete with regression
tests) in RH6.2, it makes me wonder why I fork over money for new releases from
you guys...

P.S. the expiration of bugzilla accounts is extremely annoying.

Comment 6 Nalin Dahyabhai 2000-08-21 16:08:06 UTC
The 3.1.5-4 package is the most recent test package available, currently slated
for inclusion in our next release.  Please test it and see if it fixes the
problem.

Comment 7 Need Real Name 2000-08-21 21:10:10 UTC
I already tried... when I try to install it, RPM gives me this message:

[root@martin ddm]
# rpm -Uvh autofs-3.1.5-4.i386.rpm
only packages with major numbers <= 3 are supported by this version of RPM
error: autofs-3.1.5-4.i386.rpm cannot be installed

Besides which I've already fixed the script as I described in my earlier
comments.  I'm going to send the script to autofs@linux.kernel.org and I'll CC:
you as well.


Note You need to log in before you can comment on or make changes to this bug.