Bug 1047345 - cloud-init: gateway shouldn't be mandatory on run once window
Summary: cloud-init: gateway shouldn't be mandatory on run once window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Shahar Havivi
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-30 14:55 UTC by Meni Yakove
Modified: 2014-06-12 14:11 UTC (History)
8 users (show)

Fixed In Version: org.ovirt.engine-root-3.4.0-14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25301 0 None None None Never
oVirt gerrit 26212 0 None None None Never

Description Meni Yakove 2013-12-30 14:55:14 UTC
Description of problem:
The gateway under cloud-init window in run once is mandatory and it shouldn't since not all networks have gateway.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.42.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create linux VM and "run once" the VM
2. Under "initial run" check "network" and add network with IP and NETMASK
3. Click "OK"

Actual results:
Can't "OK" as gateway is mandatory

Expected results:
Should be able to "OK" even if gateway is empty

Comment 1 Pavel Novotny 2014-04-30 10:23:49 UTC
Verified in rhevm-3.4.0-0.15.beta3.el6ev.noarch (av7).

The Gateway field is no longer mandatory in the run once dialog (as well as in the Edit VM / Initial Run dialog).

Verification steps:
1. Have a Linux-based VM with two network interfaces. Select it and open run once dialog.
2. In the Initial Run / Cloud-Init / Networks section add network eth1 with static IP 10.1.1.200 and mask 255.255.252.0
3. Submit the dialog (run once the VM).

Results:
Run once dialog is submitted and the VM is started.
Cloud-Init config drive CD is attached as usually and interface eth1 is configured:
-~-
# cat /etc/sysconfig/network-scripts/ifcfg-eth1 
# Created by cloud-init v. 0.7.2 on Wed, 30 Apr 2014 09:57:09 +0000
NETMASK=255.255.252.0
DEVICE=eth1
IPADDR=10.1.1.200
ONBOOT=yes
-~-

Comment 2 Itamar Heim 2014-06-12 14:11:17 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.