Bug 1047376 - blkid hangs while reading from /dev/fd0
Summary: blkid hangs while reading from /dev/fd0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: util-linux
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Karel Zak
QA Contact: Leos Pol
URL:
Whiteboard:
: 1081567 1082961 (view as bug list)
Depends On:
Blocks: RHEL7CCC 1080727
TreeView+ depends on / blocked
 
Reported: 2013-12-30 19:10 UTC by Berkley Shands
Modified: 2014-06-18 04:12 UTC (History)
9 users (show)

Fixed In Version: util-linux-2.23.2-16.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 11:08:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
blkid_debug (3.68 KB, text/plain)
2014-03-18 15:54 UTC, Pavel Holica
no flags Details
partitions (418 bytes, text/plain)
2014-03-18 15:54 UTC, Pavel Holica
no flags Details

Description Berkley Shands 2013-12-30 19:10:02 UTC
Description of problem:
Installing on an old SuperMicro H8DCE 2-socket AMD 940 motherboard
With ForcedEth ethernet, floppy controller enabled, but *NO* floppy
powered. Late stage install of boot block fails with grub2-install step hanging
attempting to access the floppy FD0, which in this case, does not exist.
The retry does not time out even after 30 minutes.


Version-Release number of selected component (if applicable):


How reproducible:

Install general workstation development on old AMD socket 940 motherboard.
Leave the floppy drive unpowered.


Steps to Reproduce:
1.
2.
3.

Actual results:

Hang in grub2- step trying for a floppy. <Alt><F4>
 shows grub2 step, and scrolling FD0 errors.

Expected results:

A grub2 boot block

Additional info:

Yeah, its old and in the way, but it didn't cost much :-)
The forcedeth is not a valid ethernet device either (also no big deal).

Comment 2 Pavel Holica 2014-03-17 12:10:34 UTC
I was able to reproduce the issue, and it was caused by blkid which is run inside os /bin/os-prober in function partitions.

Changing component to util-linux. blkid was from: util-linux-2.23.2-14.el7

Comment 5 Leos Pol 2014-03-18 14:15:46 UTC
Any progress with this?

Comment 6 Karel Zak 2014-03-18 14:54:57 UTC
It would be nice to have /proc/partitions from the machine. libblkid should not read fd0 by default at all. It would be also nice to have output from

 LIBBLKID_DEBUG=0xffff blkid

Comment 7 Pavel Holica 2014-03-18 15:54:08 UTC
Created attachment 876011 [details]
blkid_debug

Comment 8 Pavel Holica 2014-03-18 15:54:11 UTC
Created attachment 876012 [details]
partitions

Comment 9 Karel Zak 2014-03-19 09:28:47 UTC
Hmm... it seems that we're affected by stupid kernel regression (which will not be fixed...), see

  https://groups.google.com/forum/#!topic/linux.kernel/uj-jvmwn9yg

where kernel displays removable media in /proc/partitions now.

It will be probably necessary to add an extra filter to libblkid to ignore by default the floppies.

Comment 10 Karel Zak 2014-03-20 09:38:56 UTC
The another story are mess in return codes in the library. It should be fixed together with the floppy problem.

Comment 11 Karel Zak 2014-03-20 10:28:14 UTC
Note that there is also kernel solution, see bug #1078786.

Comment 12 Karel Zak 2014-03-24 10:40:25 UTC
Fixed by upstream commits 296d96e20e565e497e9510e6ac9b71e0a0ca447d and 37f4060225df0591ab8e1dd676dbc8115d900d4f.

Comment 17 Karel Zak 2014-03-28 13:38:24 UTC
*** Bug 1081567 has been marked as a duplicate of this bug. ***

Comment 20 Miroslav Vadkerti 2014-04-01 08:09:20 UTC
*** Bug 1082961 has been marked as a duplicate of this bug. ***

Comment 23 Ludek Smid 2014-06-13 11:08:56 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.