Bug 104746 - redhat config bind does not preserve config
Summary: redhat config bind does not preserve config
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-bind   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-20 11:34 UTC by Benny Pedersen
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-02 14:40:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Benny Pedersen 2003-09-20 11:34:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3)

Description of problem:
redhat config bind overwrites working /etc/named.conf without make a backup or save config into /etc/named.custom if it does not know some settings in the named.conf

Version-Release number of selected component (if applicable):
1.8.1-18

How reproducible:
Always

Steps to Reproduce:
1. make your setup into /etc/named.conf
2. start redhat config bind
3. save now config
4. now you lost config in /etc/named.conf

Actual Results:  all configure zones that was defined in /etc/named.conf will not work anymore since thay do not load since thay now is not configured

Expected Results:  anything in /etc/named.conf should be saved in /etc/named.custom by redhat config bind so no config settings is lost

Additional info:

i have not done the report of this old bug with i belive is a old standing one :/

Comment 1 Daniel Walsh 2003-10-02 14:40:14 UTC
Check out the latest redhat-config-bind in rawhide.

It now edits in place config files.

Dan


Note You need to log in before you can comment on or make changes to this bug.