Bug 1047518 - High Power Usage and System Temperature
Summary: High Power Usage and System Temperature
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-31 13:47 UTC by Sudhir Khanger
Modified: 2014-02-26 03:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-26 03:23:44 UTC
Type: Bug


Attachments (Terms of Use)
Powertop results (68.18 KB, text/html)
2013-12-31 13:47 UTC, Sudhir Khanger
no flags Details
dmesg (96.05 KB, text/plain)
2014-01-27 16:19 UTC, Sudhir Khanger
no flags Details
dmidecode (14.12 KB, text/plain)
2014-01-27 16:20 UTC, Sudhir Khanger
no flags Details
latest powertop results (65.52 KB, text/html)
2014-01-27 16:20 UTC, Sudhir Khanger
no flags Details

Description Sudhir Khanger 2013-12-31 13:47:52 UTC
Created attachment 843778 [details]
Powertop results

Description of problem:
From time to time system temperature gets as high as 95C along with power usage of 30W. System load and resources remain normal.

Version-Release number of selected component (if applicable):
rpm -q kernel
kernel-3.11.10-301.fc20.x86_64
kernel-3.12.5-302.fc20.x86_64


How reproducible:
It is not clear why specifically triggers the high system temperature but it is always very sudden out of nowhere.


Steps to Reproduce:
No clear steps to reproduce.

Actual results:
Sudden high system temperature.

Expected results:


Additional info:
Please let me know if you want any specific information. It is a new Fedora 20 install and I can't think of any particular software that would trigger such a high temperature. Also both top and powertop fails to point to any particular process.

Comment 1 Michele Baldessari 2014-01-01 18:55:51 UTC
Hi Sudhir,

depending on the type of machine, 30W are not all too much really ;)
Your powertop output does not add up to too much. 
The higher temperature might be due to the fans not kicking in?

What system is this? 

Can you attach here dmidecode and dmesg output?

Thanks,
Michele

Comment 2 Sudhir Khanger 2014-01-27 16:18:00 UTC
cat /proc/acpi/ibm/fan
status:         enabled
speed:          4476
level:          7
commands:       level <level> (<level> is 0-7, auto, disengaged, full-speed)
commands:       enable, disable
commands:       watchdog <timeout> (<timeout> is 0 (off), 1-120 (seconds))


systemctl status thinkfan
thinkfan.service - simple and lightweight fan control program
   Loaded: loaded (/usr/lib/systemd/system/thinkfan.service; enabled)
   Active: active (running) since Mon 2014-01-27 14:15:20 IST; 7h ago
 Main PID: 651 (thinkfan)
   CGroup: /system.slice/thinkfan.service
           └─651 /usr/sbin/thinkfan

Jan 27 14:15:20 fedora systemd[1]: Starting simple and lightweight fan control program...
Jan 27 14:15:20 fedora thinkfan[636]: Daemon PID: 651
Jan 27 14:15:20 fedora systemd[1]: Started simple and lightweight fan control program.

Fan seems to be working fine.

This is Lenovo 4177CTO ThinkPad T420i.

It seems temperature tends to go down if I suspend the system and then wake from  sleep.

Linux fedora 3.12.8-300.fc20.x86_64 #1 SMP Thu Jan 16 01:07:50 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Please see the attachment for dmesg, dmidecode and powertop.html.

PS:- Sorry for the delay in reply. I will be prompt from now on.

Comment 3 Sudhir Khanger 2014-01-27 16:19:07 UTC
Created attachment 856134 [details]
dmesg

Comment 4 Sudhir Khanger 2014-01-27 16:20:01 UTC
Created attachment 856135 [details]
dmidecode

Comment 5 Sudhir Khanger 2014-01-27 16:20:46 UTC
Created attachment 856136 [details]
latest powertop results

Comment 6 ILMostro 2014-02-07 18:53:12 UTC
I've had the same issue on my ThinkPad W520 running Fedora20 (and earlier); here's the mcelog output about the event(s):
 MCE 0
  1047  CPU 1 THERMAL EVENT TSC c01ca82b78 
  1048  TIME 1391796070 Fri Feb  7 12:01:10 2014
  1049  Processor 1 heated above trip temperature. Throttling enabled.
  1050  Please check your system cooling. Performance will be impacted
  1051  STATUS 88030003 MCGSTATUS 0
  1052  MCGCAP c09 APICID 1 SOCKETID 0 
  1053  CPUID Vendor Intel Family 6 Model 42
  1054  Hardware event. This is not a software error.
  1055  MCE 1
  1056  CPU 0 THERMAL EVENT TSC c01ca8654a 
  1057  TIME 1391796070 Fri Feb  7 12:01:10 2014
  1058  Processor 0 heated above trip temperature. Throttling enabled.
  1059  Please check your system cooling. Performance will be impacted
  1060  STATUS 88030003 MCGSTATUS 0
  1061  MCGCAP c09 APICID 0 SOCKETID 0 
  1062  CPUID Vendor Intel Family 6 Model 42
  1063  Hardware event. This is not a software error.
  1064  MCE 2
  1065  CPU 1 THERMAL EVENT TSC c01cc9fbce 
  1066  TIME 1391796070 Fri Feb  7 12:01:10 2014
  1067  Processor 1 below trip temperature. Throttling disabled
  1068  STATUS 88040002 MCGSTATUS 0
  1069  MCGCAP c09 APICID 1 SOCKETID 0 
  1070  CPUID Vendor Intel Family 6 Model 42
  1071  Hardware event. This is not a software error.
  1072  MCE 3
  1073  CPU 0 THERMAL EVENT TSC c01cca2f06 
  1074  TIME 1391796070 Fri Feb  7 12:01:10 2014
  1075  Processor 0 below trip temperature. Throttling disabled
  1076  STATUS 88040002 MCGSTATUS 0
  1077  MCGCAP c09 APICID 0 SOCKETID 0 
  1078  CPUID Vendor Intel Family 6 Model 42

Comment 7 ILMostro 2014-02-07 18:55:59 UTC
regarding the thinkfan package: It's weird that there seems to be two thinkfan.conf files; one is /etc/thinkfan.conf; the other, /etc/modprobe.d/thinkfan.conf

Comment 8 Justin M. Forbes 2014-02-24 14:05:54 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.13.4-200.fc20.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 9 ILMostro 2014-02-25 14:33:17 UTC
My issue has been resolved, though it may not necessarily due to the kernel update.  The kernel reported correctly that the temperature was at times increasing above threshold levels; however, this was (on my ThinkPad W520) "resolved" after cleaning interior hardware components (primarily case Fan), which had gathered large amount of dust.

Nevertheless, the fact that the mcelog messages were occurring with more frequency when running Fedora, as opposed to Arch or Ubuntu, should still be a cause of concern and focus for Kernel developers.  I don't know the extent of Lenovo's cooperation with the Linux community in great detail, but I do remember reading on the kernel's bugzilla reports that it was an ongoing process; is it possible to have the kernel somehow avoid "overloading" individual cores on a multi-core processor, since the messages usually point to Core 0 and/or Core 1?

Comment 10 Sudhir Khanger 2014-02-26 03:23:44 UTC
I no longer seem to have the problem in 3.13.3 so I am closing this bug.


Note You need to log in before you can comment on or make changes to this bug.