Bug 10477 - pppd hangs when pty option is used
Summary: pppd hangs when pty option is used
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-31 11:28 UTC by Joerg Dorchain
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-03 16:16:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joerg Dorchain 2000-03-31 11:28:31 UTC
I want to connect two pppd' with ssh.
The command I use for this is pppd pty 'ssh -t -i identity -l vpnuser
vpnhost.mydomain /usr/sbin/pppd'.
Then both pppds timeout on sending config-requests.
Only ssh -t -i identity -l vpnuser vpnhost.mydomain /usr/sbin/pppd gives a
connect and ppp-frames on the screen.
Using rsh instead of ssh gives the same. ppp-2.3.10 and ppp-2.3.11 give the
same.
Any Hints?

Comment 1 Nalin Dahyabhai 2000-04-03 16:16:59 UTC
This seems to work for me:
pppd pty 'rsh somehost /usr/sbin/pppd notty noauth' 10.0.0.1:10.0.0.2 noauth

I had to supply the 'noauth' flag because both systems already have default
routes, and supply the local and remote addresses because I was running both
the server and the client.

Comment 2 Joerg Dorchain 2000-04-04 14:08:59 UTC
Please understand me right that I said that my pppds don't even exchange
lcp-frames to detect they would need additional options for establishing ipcp.
Both send config-requests that never reach their counterpart.
IMHO this is a bug (if not in the pppd pty option, then in sshd), so it could be
an idea to reopen this bug-report again.
If you have problems reproducing the problem, please ask.


Note You need to log in before you can comment on or make changes to this bug.