Bug 1047946 - Inconsistent POM log4j-jboss-logmanager-1.0.2.Final-redhat-1
Summary: Inconsistent POM log4j-jboss-logmanager-1.0.2.Final-redhat-1
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: EAP 6.3.0
Assignee: Lin Gao
QA Contact: Nikoleta Hlavickova
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-02 16:42 UTC by Nikoleta Hlavickova
Modified: 2015-03-31 14:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-31 14:11:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Nikoleta Hlavickova 2014-01-02 16:42:18 UTC
log4j-jboss-logmanager-1.0.2.Final-redhat-1.pom differs from pom.xml inside log4j-jboss-logmanager-1.0.2.Final-redhat-1.jar

Dependencies defined in log4j-jboss-logmanager-1.0.2.Final-redhat-1.pom:
  <dependencies>
    <dependency>
      <groupId>org.jboss.modules</groupId>
      <artifactId>jboss-modules</artifactId>
      <version>1.2.0.Final-redhat-1</version>
      <scope>provided</scope>
    </dependency>
    <dependency>
      <groupId>org.jboss.logmanager</groupId>
      <artifactId>jboss-logmanager</artifactId>
      <version>1.4.0.Final-redhat-1</version>
      <scope>compile</scope>
    </dependency>
    <dependency>
      <groupId>org.jboss.logging</groupId>
      <artifactId>jboss-logging</artifactId>
      <version>3.1.2.GA-redhat-1</version>
      <scope>test</scope>
    </dependency>
    <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>4.10-redhat-2</version>
      <scope>test</scope>
      <exclusions>
        <exclusion>
          <artifactId>hamcrest-core</artifactId>
          <groupId>org.hamcrest</groupId>
        </exclusion>
      </exclusions>
    </dependency>
  </dependencies>

Dependencies defined in pom.xml inside log4j-jboss-logmanager-1.0.2.Final-redhat-1.jar:
    <dependencies>
        <dependency>
            <groupId>org.jboss.modules</groupId>
            <artifactId>jboss-modules</artifactId>
            <version>1.1.0.GA</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>log4j</groupId>
            <artifactId>log4j</artifactId>
            <version>1.2.16</version>
        </dependency>
        <dependency>
            <groupId>org.jboss.logmanager</groupId>
            <artifactId>jboss-logmanager</artifactId>
            <version>1.3.0.Final</version>
        </dependency>
        <dependency>
            <groupId>org.jboss.logging</groupId>
            <artifactId>jboss-logging</artifactId>
            <version>3.1.0.GA</version>
            <scope>test</scope>
        </dependency>
        <dependency>
            <groupId>junit</groupId>
            <artifactId>junit</artifactId>
            <version>4.8.2</version>
            <scope>test</scope>
        </dependency>
    </dependencies>

Comment 2 Paul Gier 2014-07-03 19:06:07 UTC
This is caused by our usage of the Maven shade plugin which changes the pom before deployment to the repository.  The issue still exists in EAP 6.3 which uses log4j-jboss-logmanager version 1.1.0.Final-redhat-2.

Looks like we tried to fix this previously [1], but I'm not sure if the fix never worked, or was accidentally reverted.  We'll probably need to work with the developer to determine whether the shade plugin usage is required.

I believe the shade plugin usage in only for adding the necessary log4j classes, so it should be safe to configure the shade plugin to retain the original pom and make the log4j dependency non transitive (provided or optional).

[1]http://pkgs.devel.redhat.com/cgit/rpms/log4j-jboss-logmanager/commit/?h=jb-eap-6-rhel-6&id=66b172d76c8c769774fe3b3ea7e8b9689c1de989

Comment 3 Nikoleta Hlavickova 2014-11-26 13:44:56 UTC
This issue appeared again in EAP 6.4.0.DR11 with log4j-jboss-logmanager-1.1.1.Final-redhat-1.

Comment 4 James Perkins 2015-03-18 21:43:55 UTC
What is the issue with the pom's differing? The version mismatch shouldn't be an issue with the shade plugin. I don't know where that would have come from.

Comment 5 Paul Gier 2015-03-30 14:22:03 UTC
The version mismatch comes from the Maven extension that we were using in previous releases, but we are not using that anymore.  I checked that the versions match between the two poms in the current build (1.1.1.Final-redhat-1).

I agree it's probably fine for the POMs to have a slightly different dependency set (as long as the versions match), so if Nikoleta is ok with this, then we can close this as won't fix.

Comment 6 Lin Gao 2015-03-31 01:37:19 UTC
@Nikoleta, What do you think Paul's proposal of closing it as won't fix?

Comment 7 Nikoleta Hlavickova 2015-03-31 11:19:30 UTC
OK. The versions match in 1.1.1.Final-redhat-1


Note You need to log in before you can comment on or make changes to this bug.