Bug 104798 - marvosym font missing in rh9 tetex
marvosym font missing in rh9 tetex
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-22 05:09 EDT by SA
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 07:32:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SA 2003-09-22 05:09:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
the fonts for the marvosym package appear screwed up.

If I try to use the \EUR symbol (euro) I get the following message
when I try to view the dvi file:

xdvi trento_exp.dvi
kpathsea: Running mktexpk --mfmode cx --bdpi 300 --mag 0+270/300 --dpi 270 fmvr8x
mktexpk: Running gsftopk fmvr8x 270
gsftopk(k) version 1.17GNU Ghostscript 7.05: Unrecoverable error, exit code 1
/705
[0gs: Error: /undefined in j�
gs: Operand stack:
gs:    --dict:8/12(L)--   --dict:8/12(L)--   Private   --dict:13/16(L)--  
--dict:8/12(L)--   CharStrings   --dict:205/206(L)--   n  
(\020\2771py\311\2552\316\272u\315\255\356?\352\327p,\035\207\232\0256\252\000'\307\245\345\013j\304\324\024V\310#r\001\321\256\013v?\350\030\363\t\020V?\206)
gs: Execution stack:
gs:    %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   2   3   %oparray_pop   --nostringval--   --nostringval--  
--nostringval--   --nostringval--
gs: Dictionary stack:
gs:    --dict:1050/1123(ro)(G)--   --dict:0/20(G)--   --dict:112/200(L)--  
--dict:1050/1123(ro)(G)--   --dict:13/16(L)--   --dict:205/206(L)--
gs: Current allocation mode is local

Premature end of file
grep: fmvr8x.log: No such file or directory
mktexpk: `gsftopk fmvr8x 270' failed to make fmvr8x.270pk.
kpathsea: Appending font creation commands to missfont.log.
xdvi.bin: Can't find font fmvr8x.270pk
xdvi.bin: Not all pixel files were found

This has occurred since installing RH 9

Any suggestions? 

Thanks,

SA
no_spam at ntlworld dot com

Version-Release number of selected component (if applicable):
tetex-1.0.7-66

How reproducible:
Always

Steps to Reproduce:
1. compile any latex file using the marvosym package and the \EUR symbol
2. use dvips or xdvi to view the file
3.
    

Actual Results:  dvips / xdvi crash

Expected Results:  you should be able to make docs with the euro symbol

Additional info:
Comment 1 Tim Waugh 2003-10-02 08:29:54 EDT
It works in the current test release.
Comment 2 SA 2003-10-18 07:45:30 EDT
I am not sure I understand:

According to redhat.com tetex 1.0.7 - 66 is the latest release
and this certainly doesn't work on my installation.

The file latex fine but the xdvi view fails to find the font and either crashes
or subsitutes a font (in which case the euro symbol is not visible).

Further testing suggests an XDVI problem since dvips works ok.


>> cat test.tex
\documentclass{report}
\usepackage{marvosym}
\begin{document}
This is a test:
%this is without the euro symbol
this is with the euro symbol \EUR
\end{document}
>> latex test.texThis is TeX, Version 3.14159 (Web2C 7.3.1)
(test.tex
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, i
talian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/report.cls
Document Class: report 2001/04/21 v1.4e Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/latex/misc/marvosym.sty) (test.aux) [1] (test.aux) )
Output written on test.dvi (1 page, 328 bytes).
Transcript written on test.log.
>> xdvi test.dvi
kpathsea: Running mktexpk --mfmode cx --bdpi 300 --mag 1+0/300 --dpi 300 fmvr8x
mktexpk: Running gsftopk fmvr8x 300
gsftopk(k) version 1.17GNU Ghostscript 7.05: Unrecoverable error, exit code 1
/705
[0gs: Error: /undefined in j�
gs: Operand stack:
gs:    --dict:8/12(L)--   --dict:8/12(L)--   Private   --dict:13/16(L)--  
--dict:8/12(L)--   CharStrings   --dict:205/206(L)--   n  
(\020\2771py\311\2552\316\272u\315\255\356?\352\327p,\035\207\232\0256\252\000'\307\245\345\013j\304\324\024V\310#r\001\321\256\013v?\350\030\363\t\020V?\206)
gs: Execution stack:
gs:    %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   2   3   %oparray_pop   --nostringval--   --nostringval--  
--nostringval--   --nostringval--
gs: Dictionary stack:
gs:    --dict:1050/1123(ro)(G)--   --dict:0/20(G)--   --dict:112/200(L)--  
--dict:1050/1123(ro)(G)--   --dict:13/16(L)--   --dict:205/206(L)--
gs: Current allocation mode is local

Premature end of file
grep: fmvr8x.log: No such file or directory
mktexpk: `gsftopk fmvr8x 300' failed to make fmvr8x.300pk.
kpathsea: Appending font creation commands to missfont.log.
xdvi.bin: can't find font fmvr8x; using cmr10 instead at 300 dpi.
Character 164 not defined in font cmr10

>> ## no euro symbol !
>> ## Also via dvips and gv all is good
>> dvips test.dvi -o test.ps
This is dvips(k) 5.86 Copyright 1999 Radical Eye Software (www.radicaleye.com)
' TeX output 2003.10.18:1239' -> test.ps
<texc.pro><texps.pro>. <marvosym.pfb>[1]
>> gv test.ps
>> % works fine
>> rpm -qa |grep dvi
tetex-dvips-1.0.7-66
tetex-xdvi-1.0.7-66
Comment 3 Tim Waugh 2003-10-18 12:21:08 EDT
It works in the current test release (Severn).  In other words, the next release
will contain the fix.
Comment 4 SA 2003-12-14 12:19:25 EST
Any chance of the fix being available in the mean time? (or a
work around?
Comment 5 Tim Waugh 2004-01-28 07:31:49 EST
This is fixed in Fedora Core 1.

Note You need to log in before you can comment on or make changes to this bug.