Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1048384 - many errors in journal log
Summary: many errors in journal log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-03 21:11 UTC by Jon McCann
Modified: 2015-04-28 12:59 UTC (History)
7 users (show)

Fixed In Version: abrt-2.2.2-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-28 12:59:18 UTC
Type: Bug


Attachments (Terms of Use)
patch (2.62 KB, text/x-c)
2014-01-06 19:15 UTC, Jon McCann
no flags Details
patch (3.64 KB, text/x-c)
2014-01-06 19:15 UTC, Jon McCann
no flags Details

Description Jon McCann 2014-01-03 21:11:26 UTC
I have thousands of abrt errors in the journal log. (this boot alone there are 18340)

Here is a sample:
Jan 02 17:59:54 Quoll abrtd[492]: Can't open file '/var/tmp/abrt/oops-2013-01-17-01:37:01-15485-1/type': No such file or directory
Jan 02 17:59:54 Quoll abrtd[492]: Missing or empty file: type
Jan 02 17:59:54 Quoll abrtd[492]: Unlocked '/var/tmp/abrt/oops-2013-01-17-01:37:01-15485-1/.lock' (no or corrupted 'type' file)

Jan 02 18:00:15 Quoll abrtd[492]: Init complete, entering main loop
Jan 02 19:19:15 Quoll abrt-hook-ccpp[4575]: Saved core dump of pid 4574 (/usr/bin/plymouth) to /var/tmp/abrt/ccpp-2014-01-02-19:19:15-4574 (475136 bytes)
Jan 02 19:19:15 Quoll abrt-server[4576]: Can't open file '/var/tmp/abrt/oops-2013-01-17-01:37:01-15485-1/type': No such file or directory
Jan 02 19:19:15 Quoll abrt-server[4576]: Missing or empty file: type
Jan 02 19:19:15 Quoll abrt-server[4576]: Unlocked '/var/tmp/abrt/oops-2013-01-17-01:37:01-15485-1/.lock' (no or corrupted 'type' file)

This makes the journal quite large and adds a lot of noise that makes it hard to find other problems.

Comment 1 Jakub Filak 2014-01-06 07:18:58 UTC
ABRT never deletes the detected crashes by itself, unless disk is full, even if crash data are corrupted. 'Missing or empty file: type' message can be caused by either the unsuccessful upgrade from abrt-2.1.6 or systemd-tmpfiles. If you are sure that you have already reported/processed a crash stored in /var/tmp/abrt/oops-2013-01-17-01:37:01-15485-1, you can safely delete that directory.

Comment 2 Jon McCann 2014-01-06 11:00:27 UTC
I have never touched those directories myself so not sure what went wrong. But my point here is that even if something went wrong we should be handling it better than this. What is actually printing out those warnings and are they really warnings?

Comment 3 Jon McCann 2014-01-06 19:15:37 UTC
Created attachment 846280 [details]
patch

Doesn't address the core problem that perhaps these directories should be remove automatically but no sense warning about them all day long. Warnings are best for things that are problems that interfere with normal operation and these clearly don't.

Comment 4 Jon McCann 2014-01-06 19:15:59 UTC
Created attachment 846281 [details]
patch

Comment 6 Marek Zdunek 2014-11-13 20:30:44 UTC
same here

abrt.x86_64 2.2.2-1.fc20   

from log

...
lis 12 22:06:08 amd64 abrtd[705]: Can't open file '/var/tmp/abrt/pyhook-2011-08-03-16:34:18-1766/type': Nie ma takiego pliku ani katalogu
lis 12 22:06:08 amd64 abrtd[705]: Missing or empty file: type
lis 12 22:06:08 amd64 abrtd[705]: Unlocked '/var/tmp/abrt/pyhook-2011-08-03-16:34:18-1766/.lock' (no or corrupted 'type' file)
lis 12 22:06:08 amd64 systemd[1]: Started GNOME Display Manager.
lis 12 22:06:08 amd64 abrtd[705]: Can't open file '/var/tmp/abrt/pyhook-2011-08-03-16:34:18-1766/type': Nie ma takiego pliku ani katalogu
lis 12 22:06:08 amd64 abrtd[705]: Missing or empty file: type
lis 12 22:06:08 amd64 abrtd[705]: Unlocked '/var/tmp/abrt/pyhook-2011-08-03-16:34:18-1766/.lock' (no or corrupted 'type' file)
lis 12 22:06:08 amd64 abrtd[705]: Can't open file '/var/tmp/abrt/pyhook-2011-08-03-16:34:18-1766/type': Nie ma takiego pliku ani katalogu
lis 12 22:06:08 amd64 abrtd[705]: Missing or empty file: type
lis 12 22:06:08 amd64 abrtd[705]: Unlocked '/var/tmp/abrt/pyhook-2011-08-03-16:34:18-1766/.lock' (no or corrupted 'type' file)
lis 12 22:06:08 amd64 systemd-logind[720]: New seat seat0.
lis 12 22:06:08 amd64 abrtd[705]: Can't open file '/var/tmp/abrt/pyhook-2011-08-03-16:34:18-1766/type': Nie ma takiego pliku ani katalogu

Comment 7 Fedora Update System 2015-02-16 13:56:01 UTC
abrt-2.2.2-2.fc20,libreport-2.2.3-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/abrt-2.2.2-2.fc20,libreport-2.2.3-3.fc20

Comment 8 Fedora Update System 2015-02-17 08:10:07 UTC
Package abrt-2.2.2-2.fc20, libreport-2.2.3-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.2.2-2.fc20 libreport-2.2.3-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2191/abrt-2.2.2-2.fc20,libreport-2.2.3-3.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-04-28 12:59:18 UTC
abrt-2.2.2-2.fc20, libreport-2.2.3-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.