Bug 104843 - emacs expects `brasileiro' language, but none is provided
emacs expects `brasileiro' language, but none is provided
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aspell-pt_BR (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-22 15:38 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 50:0.50-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 15:27:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-09-22 15:38:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
GNU Emacs's spell checker expects there to be a language named `brasileiro' for
pt_BR, but aspell-pt_BR does not provide such a language.

Version-Release number of selected component (if applicable):
aspell-pt_BR-2.4-13 emacs-21.3-6

How reproducible:
Always

Steps to Reproduce:
1.Start GNU Emacs
2.Click on Tools -> Spell Checking -> Select Brasileiro Dict
3.Start the spell checking

Actual Results:  Error: The file "/usr/lib/aspell/brasileiro" can not be opened
for reading

Expected Results:  Since this is the default name used by GNU Emacs, it should
work.  We already have /usr/lib/aspell/brazilian, but not brasileiro.

Additional info:
Comment 1 Gustavo Maciel Dias Vieira 2004-06-21 15:45:58 EDT
I believe the aspell-pt_BR package is unnecessary (see bug #126448).
My fix for the bug #110016 also solves this bug.
Comment 2 Eido Inoue 2004-10-21 15:27:30 EDT
'brasileiro' has been added as an alias to pt_BR for 0.50 series to
the modern -pt package (which includes Brazilian Portuguese)

Note You need to log in before you can comment on or make changes to this bug.