Bug 1048650 - hwcert-client-1.7.0-62.1 shows "unable to initialize libusb: -99" messages when there is no USB controls
Summary: hwcert-client-1.7.0-62.1 shows "unable to initialize libusb: -99" messages wh...
Keywords:
Status: CLOSED DUPLICATE of bug 1022754
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Retired
Component: Test Suite (tests)
Version: 1.7.0
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-06 02:36 UTC by Adam Ru
Modified: 2014-01-09 15:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-09 15:01:29 UTC


Attachments (Terms of Use)

Description Adam Ru 2014-01-06 02:36:16 UTC
Description of problem:

hwcert-client-1.7.0-62.1 shows "unable to initialize libusb: -99" messages when there is no USB controls 


Version-Release number of selected component (if applicable):

[root@prme-swcert-dhcp112 ~]# uname -a
Linux prme-swcert-dhcp112.eng.vmware.com 3.10.0-54.0.1.el7.x86_64 #1 SMP Tue Nov 26 16:51:22 EST 2013 x86_64 x86_64 x86_64 GNU/Linux

[root@prme-swcert-dhcp112 ~]# rpm -qa | grep hwcert
hwcert-client-1.7.0-62.1.el7.noarch
hwcert-client-info-1.7.0-62.1.el7.noarch


How reproducible:

remove the USB controls from the Virtual Machine and run hwcert.


Steps to Reproduce:
1.
2.
3.

Actual results:

There are three line "unable to initialize libusb: -99" during the tests planning.
When add USB controller back to the virtual machine the messages will not show.

[root@prme-swcert-dhcp112 ~]# hwcert
The Red Hat Hardware Certification Test Suite

Would you like to submit the results to the hardware catalog? (y|n) n
response: n
Saving current results to:
/var/hwcert/store/VMware, Inc./VMware/ESXi 6.0/x86_64/RHEL/7/hwcert-results-prme-swcert-dhcp112.eng.vmware.com-20140103082316.xml.gz

Copy results to test server 10.115.161.119? (y|n) n
Warning: could not determine host for disk /dev/fd0 (/devices/platform/floppy.0/block/fd0)
unable to initialize libusb: -99
unable to initialize libusb: -99
unable to initialize libusb: -99


Expected results:

Expect to hide the messages during the tests planning as there is actually no USB controller.

The hwcert-client-1.6.5 on rhel6 will not have this messages when there is no USB controller.


Additional info:

Comment 1 Greg Nichols 2014-01-09 15:01:29 UTC
Closing as duplicate of bug 1022754; while it looks arch-specific, the fix is not, since it avoids calling lsusb if no controller is found.

*** This bug has been marked as a duplicate of bug 1022754 ***


Note You need to log in before you can comment on or make changes to this bug.