Bug 104878 - package PINE does not install
package PINE does not install
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: pine (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-22 21:08 EDT by Dan Egli
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-23 00:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Egli 2003-09-22 21:08:21 EDT
Description of problem:
The version of PINE in RawHide won't install because it says it's missing the
file libcom_err.so.3

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install (or upgrade to) RawHide
2. Install latest Kerberos package (I believe that is the package meant to give
the missing file)
3. try to install pine
    
Actual results:
from apt-get:

[root@breakme root]# apt-get install pine
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  pine: Depends: libcom_err.so.3
E: Broken packages


or from straight RPM:

[root@breakme root]# rpm -Uvh
http://ftp.redhat.com/pub/redhat/linux/9/en/os/i386/RedHat/RPMS/pine-4.44-18.i386.rpm
Retrieving
http://ftp.redhat.com/pub/redhat/linux/9/en/os/i386/RedHat/RPMS/pine-4.44-18.i386.rpm
warning: /var/tmp/rpm-xfer.7QYFkh: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
        libcom_err.so.3 is needed by pine-4.44-18


Expected results:
should download and install pine

Additional info:
Comment 1 Bill Nottingham 2003-09-23 00:20:16 EDT
pine is not currently *in* rawhide; the Red Hat Linux 9 version may not work on
a current system.
Comment 2 Mike A. Harris 2003-09-23 12:14:24 EDT
Search bugzilla for bugs related to libcom_err and you might find something
helpful. Other than that however, what Bill says is correct, pine is not
in rawhide, it is removed.
Comment 3 Dan Egli 2003-09-24 00:35:44 EDT
Is there a specific reason why pine was removed from rawhide? After all, it is
one of the most easily taught MUAs you have released.
Comment 4 Mike A. Harris 2003-09-24 01:57:20 EDT
There are several reasons for pine being removed, however bugzilla isn't
really the place to discuss that.  I will however say that there is a new
pine replacement called "cone" developed by the Courier MTA people which is
under a true open source license (GPL).  While cone showed up on the scene
too late to be included in our next OS release, I plan on very closely
investigating "cone" for possible inclusion in a future OS release as a
replacement for those who prefer the pine MUA.  The GPL'd nano text editor
is in rawhide currently as a replacement for pico also.

While I won't comment further about this in bugzilla, feel free to discuss
it on the Red Hat fedora-test-list@redhat.com if you wish, and someone
may possibly provide details.

Note You need to log in before you can comment on or make changes to this bug.