Bug 10488 - JPEG not in /usr/share/magic
Summary: JPEG not in /usr/share/magic
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: file   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-31 18:15 UTC by Justin R. Miller
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-15 15:15:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin R. Miller 2000-03-31 18:15:31 UTC
Hi,

In using a script I wrote that performs 'file' on a file and greps for
'JPEG' or 'GIF', I noticed that JPEGs weren't coming through.  Seems there
is no entry for JPEG in the new magic file.  It was there in the old one...

Thanks,
Justin

Comment 1 Jeff Johnson 2000-05-15 15:15:59 UTC
Fixed in file-3.30-1.

bash$ grep -i JPEG /usr/share/magic
# JPEG images
#       0       string          \377\330\377\340        JPEG file
# both of which turn into "JPEG image data" here.
0       beshort         0xffd8          JPEG image data
# HSI is Handmade Software's proprietary JPEG encoding scheme
0       string          hsi1            JPEG image data, HSI proprietary
# JPEG images
#       0       string          \377\330\377\340        JPEG file
# both of which turn into "JPEG image data" here.
0       beshort         0xffd8          JPEG image data
# tests are not fool-proof since some perfectly valid JPEGs are currently
# HSI is Handmade Software's proprietary JPEG encoding scheme
0       string          hsi1            JPEG image data, HSI proprietary
bash$ rpm -q file
file-3.30-1


Note You need to log in before you can comment on or make changes to this bug.