Bug 104896 - Submitting .desktop, .keys and .mime entries
Submitting .desktop, .keys and .mime entries
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: redhat-menus (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Nickell
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-23 08:19 EDT by Gérard Milmeister
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 12:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2003-09-23 08:19:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701
Galeon/1.3.9

Description of problem:
Most applications, especially commercial ones, don't come with
their .desktop, .keys and .mime files, for example Maple
and Mathematica.

It would be nice if there was an online form where one
could submit missing entries including icons for file types
and for applications. Also the mime types already present
have missing information such as descriptions and icons.
Just like the translation databases their could be such
a database where information could be supplied by volunteers.

Also I noticed that where .desktop files exist, they sometimes
don't turn up in the menu, because the Categories entry isn't
matched. It would be nice, if for example Maple had a category
named "Mathematics" this would turn up as a new submenu in
the main menu (but only if the maple is actually present).

A useful extension to the file types preferences would be
a flat view that can be sorted by description or extension, because
of some inconsistencies it is not always clear where in the
hierarchy a mime type would reside. The descriptions of the mime
types should also follow a more consistent phrasing (lower-, uppercase
etc...)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

    

Additional info:
Comment 1 Seth Nickell 2004-11-01 12:01:10 EST
A nice idea, but should probably be done in the context of
freedesktop.org not as a RH specific thing.

Note You need to log in before you can comment on or make changes to this bug.