Bug 104897 - RFE: Can't setup NAT with redhat-config-network
RFE: Can't setup NAT with redhat-config-network
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
: 161338 (view as bug list)
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2003-09-23 08:57 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:11:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-09-23 08:57:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.1.4322)

Description of problem:
It would be great if we could use redhat-config-network to configure a box 
with 2 NICs as a NAT router and forward ports.

Version-Release number of selected component (if applicable):
any

How reproducible:
Always

Steps to Reproduce:
1.It's
2.not
3.implemented is it?
    

Actual Results:  Can't get NAT to work.

Expected Results:  NAT and portforwarding working :)

Additional info:

Maybe I'm just too lame to do it right but we NEED an easy way to do this.
Comment 1 Harald Hoyer 2003-09-23 09:02:46 EDT
yeah, right you are.. is on the TODO list :)
Comment 2 Need Real Name 2003-09-23 10:10:40 EDT
Thanks 4 the fast response Harald!
Feel free to email me if you need vitims that help testing ^^
Comment 3 manuel wolfshant 2003-12-31 15:46:50 EST
I am a huge fan of a program called "firewall builder"
(http://www.fwbuilder.org/). No, I do not use it, but all beginners I
have shown it to gave a very positive feedback. Yes, I know it's much
more then just adding net.ipv4.ip_forward = 1 to sysctl.conf and
iptables -j SNAT to /etc/sysconfig/iptables. Nevertheless, I think
that  redhat-config-network should not deal with the NAT/port
forwarding stuff, to me it looks much closer to a
redhat-config-securitylevel job.
Comment 4 Harald Hoyer 2006-01-24 09:49:22 EST
*** Bug 161338 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.