Bug 104905 - old amp RPMs (i386 & src) for RHL 5.x completely break on RPM 4.x (100% reproducible, URLs included)
old amp RPMs (i386 & src) for RHL 5.x completely break on RPM 4.x (100% repro...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-23 10:07 EDT by Barry K. Nathan
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 16:00:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -qp --qf '[%{*:xml}\n]' amp*6.rpm > amp.xml (7.04 KB, text/plain)
2003-09-24 15:42 EDT, Jeff Johnson
no flags Details

  None (edit)
Description Barry K. Nathan 2003-09-23 10:07:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030910

Description of problem:
I downloaded & attempted to install these RPMs (originally on a Mandrake cooker
with RPM 4.2, but I've tried again on various RHL releases and taroon beta 2, too):

ftp://speakeasy.rpmfind.net/linux/contrib/libc6/i386/amp-0.7.6-3.i386.rpm
ftp://speakeasy.rpmfind.net/linux/contrib/libc6/SRPMS/amp-0.7.6-3.src.rpm

These choke in really weird ways on RPM 4.x (see "Actual Results" in this bug
report). RPM 3.0.x (3.0.3, I think) on RHL 4.2 doesn't seem to have problems
with these packages (the i386 fails to install because of no glibc, but the src
rpm installs fine), and rpm2cpio gives me cpio packages that pax can extract
without incident.

Version-Release number of selected component (if applicable):
rpm-4.2.1-3 (and every other 4.0.4/4.2.x I've tried)

How reproducible:
Always

Steps to Reproduce:
1. Download the two RPMs available at the URLs above.
2. Try to install one (or both).
3. BOOM.
    

Actual Results:
[root@localhost amp]# rpm -ivh amp-0.7.6-3.i386.rpm
warning: amp-0.7.6-3.i386.rpm: V3 RSA/MD5 signature: NOKEY, key ID d21da329
Preparing...                ########################################### [100%]
   1:amp                    ########################################### [100%]
error: unpacking of archive failed on file bin/amp: cpio: Archive file not in header
[root@localhost amp]# rpm -ivh amp-0.7.6-3.src.rpm
warning: amp-0.7.6-3.src.rpm: V3 RSA/MD5 signature: NOKEY, key ID d21da329
warning: user nimir does not exist - using root
warning: group staff does not exist - using root
warning: user nimir does not exist - using root
warning: group staff does not exist - using root
   1:amp                    ########################################### [100%]
error: unpacking of archive failed on file amp-0.7.6.tgz: cpio: Archive file not
in header


Expected Results:  I'm not quite sure what I was expecting, but this wasn't
it... Even if the binary RPM has to choke for some reason, I was hoping for the
SRPM to install. The SRPM, in fact, manages to install the spec file but not the
source tarball AFAICT -- IMO it would be better to install all or nothing; that
way at least I'd know for sure what got installed without having to dig through
/usr/src/RPM [on my Mandrake system].

The SRPM installs properly on RPM 3.0.3 (I think, 3.0.x anyway), on RHL 4.2.

Additional info:

I have no idea if RPMs this old are supported by RPM 4.x, but I'm submitting
this bug report just in case they're supposed to be.
Comment 1 Jeff Johnson 2003-09-24 15:26:05 EDT
This is probably fixable if necessary. Could you
attach the pkgs and
    rpm -q --qf 'rpmversion: %rpmversion) built: %{buildtime:date}' pkgs
output please? Thanks ...
Comment 2 Jeff Johnson 2003-09-24 15:26:41 EDT
Sorry, just noted the url's, i will do. Thanks for report.
Comment 3 Jeff Johnson 2003-09-24 15:37:27 EDT
Heh, really really old packages:

$ rpm -qp --qf 'rpmversion: %{rpmversion} built %{buildtime:date}\n' amp*
warning: amp-0.7.6-3.i386.rpm: V3 RSA/MD5 signature: NOKEY, key ID d21da329
rpmversion: 2.4.12 built Tue 28 Apr 1998 06:19:57 AM EDT
rpmversion: 2.4.12 built Tue 28 Apr 1998 06:19:57 AM EDT
Comment 4 Jeff Johnson 2003-09-24 15:42:44 EDT
Created attachment 94691 [details]
rpm -qp --qf '[%{*:xml}\n]' amp*6.rpm > amp.xml

Here's the dump of the header metadata.
Comment 5 Jeff Johnson 2003-09-24 15:54:55 EDT
Here's the src.rpm failure mode reproduced:
$ xrpm -ivv amp-0.7.6-3.src.rpm
D: ============== amp-0.7.6-3.src.rpm
D: Expected size:       103043 = lead(96)+sigs(268)+pad(4)+data(102675)
D:   Actual size:       103011
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Pubkeys rdonly mode=0x0
warning: amp-0.7.6-3.src.rpm: V3 RSA/MD5 signature: NOKEY, key ID d21da329
D:      added source package [0]
D: found 1 source and 0 binary packages
D: Expected size:       103043 = lead(96)+sigs(268)+pad(4)+data(102675)
D:   Actual size:       103011
warning: user nimir does not exist - using root
warning: group staff does not exist - using root
warning: user nimir does not exist - using root
warning: group staff does not exist - using root
amp-0.7.6-3
D: ========== Directories not explictly included in package:
D:          0 /X/amp/
D:          1 /X/amp/
D: ==========
D: fini      100644  1 (   0,   0)      1324 /X/amp/amp-0.7.6.spec;3f71f62d
D: undo      100664  1 (1072,  10)    100337 amp-0.7.6.tgz unknown
GZDIO:       1 reads,     8192 total bytes in 0.000 secs
error: unpacking of archive failed on file amp-0.7.6.tgz: cpio: Archive file not
in header
D: closed   db index       /var/lib/rpm/Pubkeys
D: closed   db index       /var/lib/rpm/Packages
Comment 6 Jeff Johnson 2003-09-24 16:00:52 EDT
And here is workaround:

$ /usr/lib/rpm/rpm2cpio.sh amp-0.7.6-3.src.rpm | cpio -itv
-rw-r--r--   1 1072     wheel        1324 Apr 28  1998 amp-0.7.6.spec
-rw-rw-r--   1 1072     wheel      100337 Aug 27  1997 amp-0.7.6.tgz
200 blocks

Use -dim instead of -itv to extract.

Rebuild strongly encouraged, this is V2 packaging, and a.out
executable needs to die even if still supported by kernel/glibc somehow.

WONTFIX because of age of packaging. Can/will fix if/when necessary,
I see little reason to mess around with V2 packaging in the year 2003.
Comment 7 Barry K. Nathan 2003-09-24 23:32:54 EDT
Correction: That package contains an ELF executable, not a.out.

Anyway, since rpm2cpio works, WONTFIX is fine with me.

Note You need to log in before you can comment on or make changes to this bug.