Bug 104914 - deprecated datetime-function in postgresql >7.2 avoids usage of postgresql-backend
deprecated datetime-function in postgresql >7.2 avoids usage of postgresql-ba...
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gnucash (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-23 11:09 EDT by Lars Herrmann
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.8.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-23 15:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Herrmann 2003-09-23 11:09:24 EDT
Description of problem:

With gnucash you can not use postgresql as backend, because postgresql >7.2 does
no longer support datetime('NOW').

Version-Release number of selected component (if applicable):
gnucash-1.8.5-1.src.rpm

How reproducible:
try to save a gnucash account set to postgres://localhost/anydb. After the
querie: shall I create your database? you get a error message.

Postgresql says:  function datetime("unknown") does not exit

Additional info:

The patch from
http://www.mail-archive.com/gnucash-devel@lists.gnucash.org/msg02508.html works.

I simply changed it in /usr/lib/gnucash/libgncmod-backend-postgres.so.0.0.0 and
it worked.
Comment 1 Bill Nottingham 2003-09-23 15:07:22 EDT
This is already fixed in later gnucash releases. Will be in 1.8.7-1.

Note You need to log in before you can comment on or make changes to this bug.