Bug 104919 - CMS Folder permission UI should not display the "search for persons or groups" form for adding custom permissions when the folder inherits permissions from parent
Summary: CMS Folder permission UI should not display the "search for persons or groups...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: ui   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 108447
TreeView+ depends on / blocked
 
Reported: 2003-09-23 15:57 UTC by Scott Seago
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 15:35:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Seago 2003-09-23 15:57:53 UTC
Description of problem:
CMS Folder permission UI should not display the "search for persons or groups"
form for adding custom permissions when the folder inherits permissions from
parent. This should only be an option for folders with custom permissions.

Version-Release number of selected component (if applicable):
trunk (probably 6.0 too)

How reproducible:
always

Steps to Reproduce:
1.browse to a folder with no custom permissions
2. The form with the following text is visible: "Search for persons or groups to
grant direct permissions to"
3.
    
Actual results:
For non-custom folder permissions, add user/group form is visible, and it
actually lets me add additional permissions to the folder (although these
additional permissions don't appear in the list until I later select the "use
custom permissions" link

Expected results:
This should be hidden for folders which inherit permissions. Note that this
seems to be a default visibility issue, since the form disappears if I select
"use custom permissions" and then "restore default permissions"

Additional info:
In addition to fixing the visibility, the form itself should probably do some
checking so as to prevent the user from adding custom permissions when the
folder inherits its permissions from the parent (i.e. the context of the folder
is not null)


Note You need to log in before you can comment on or make changes to this bug.