Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1049203 - Copy files failed within win7 guest and win8 guest with ide and e1000/rtl8139 attached
Summary: Copy files failed within win7 guest and win8 guest with ide and e1000/rtl8139...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Dmitry Fleytman
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 08:23 UTC by Min Deng
Modified: 2014-02-11 10:26 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-11 10:26:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (87.60 KB, image/png)
2014-01-07 08:24 UTC, Min Deng
no flags Details
error2 (77.73 KB, image/png)
2014-01-07 08:38 UTC, Min Deng
no flags Details
steps (812.57 KB, application/zip)
2014-01-13 06:47 UTC, Min Deng
no flags Details

Description Min Deng 2014-01-07 08:23:00 UTC
Description of problem:
Boot up a guest with ide and e1000 device and login,copy files about 5M from windows server but failed.

Version-Release number of selected component (if applicable):
kernel-3.10.0-64.el7.x86_64
qemu-kvm-rhev-1.5.3-31.el7.x86_64

How reproducible:
many times
Steps to Reproduce:
1.boot up guest with the following cli
  /usr/libexec/qemu-kvm -M pc -m 2G -smp 2 -cpu host -usb -device usb-tablet -drive file=win7-32-install.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup0,downscript=no -device e1000,netdev=hostnet2,mac=00:53:55:13:41:32,bus=pci.0,addr=0x6 -uuid d7f88451-69f7-439c-b4f6-599faeae7286 -no-kvm-pit-reinjection -chardev socket,id=aa,path=/tmp/monitor-win7-32-balloon,server,nowait -mon chardev=aa,mode=readline -vnc :2 -vga cirrus -name win7-32-balloon-74 -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=0 -monitor stdio -device virtio-balloon-pci,id=balloon0 -cdrom en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso
2.Login in guest and \\10.66.73.47\... (our windows server)
3.copy some files from windows server 

Actual results:
The file (only 5M) wasn't copied due to network connection error

Expected results:
The file can be copied to guest no matter how big it was.

Additional info:

Comment 1 Min Deng 2014-01-07 08:24:03 UTC
Created attachment 846507 [details]
screenshot

Comment 3 Min Deng 2014-01-07 08:38:49 UTC
Created attachment 846511 [details]
error2

Comment 6 Yvugenfi@redhat.com 2014-01-12 15:13:48 UTC
Hi,

We cannot reproduce the issue with the same qemu version on RHEL 7 host.

Do you see that the file is starting to copy (do you see any progress in Windows GUI)?

What is the status of network connection before you copy? In the first screenshot network icon has a yellow exclamation mark (usually it means that the NIC didn't get IP address).

Is there any problem with network after the connection failed? 
If you ran ping during the copy - what do you see?


Thanks,
Yan.

Comment 8 Min Deng 2014-01-13 06:46:58 UTC
(In reply to Yan Vugenfirer from comment #6)
> Hi,
> 
> We cannot reproduce the issue with the same qemu version on RHEL 7 host.
> 
> Do you see that the file is starting to copy (do you see any progress in
> Windows GUI)?
  yes,see that the files was starting to copy.

> 
> What is the status of network connection before you copy? In the first
> screenshot network icon has a yellow exclamation mark (usually it means that
> the NIC didn't get IP address).

  Make sure the guest could obtain ip before starting copying.

> 
> Is there any problem with network after the connection failed? 
> If you ran ping during the copy - what do you see?

  It still could reach to our windows server by this 
  \\192.168.0.2 and also can browsed files and ping was ok.
> 
> 
> Thanks,
> Yan.

  I captured several screen shots for this bug so please have a look on them.
Any issues please let me know.

Best Regards,
Min

Comment 9 Min Deng 2014-01-13 06:47:41 UTC
Created attachment 849165 [details]
steps

Comment 20 Min Deng 2014-01-17 02:26:56 UTC
Hi Yan,

   Most of our hosts have this issue so it will effects our whql testing,is there any progress for this bug ? Thanks in advance.

Best Regards
Min

Comment 23 juzhang 2014-01-20 02:46:39 UTC
Hi Min,

Could you have a look comment22 and add your comment?

Best Regards,
Junyi


Note You need to log in before you can comment on or make changes to this bug.