Bug 104948 - file corruption copy gunzip tar
file corruption copy gunzip tar
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-23 15:54 EDT by Shane Ripley
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-01 16:54:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Ripley 2003-09-23 15:54:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When copying, unzipping, untaring large files (1.8GB) there is intermittent 
data corruption. The file sizes are the same but when diff or cmp is run there 
are 4 to 8 bytes of corrupt data. The problem was reproducible on 3 separate 
machines, and rebooting the servers fixed the problem temporarily. We’ve run 
hardware diags on all 3 machines with no failures. The servers are:

Compaq DL380s 6GB RAM 
2 Intel Xeon 2.8GHz processors


Version-Release number of selected component (if applicable):
kernel-enterprise-2.4.9-e.18

How reproducible:
Sometimes

Steps to Reproduce:
1. cp 2-gig-file 2-gig-file.new
2. cmp -l 2-gig-file 2-gig-file.new
3.
    

Actual Results:  Displayed several lines of differences.

Expected Results:  Should have returned nothing. I.e. no difference in files.

Additional info:

All machines have the CD versions of all RPMS. Only the Enterprise kerel has 
been upgraded to e.18
Comment 1 Shane Ripley 2003-10-01 16:54:36 EDT
Upgrading to the e.27 kernel seems to have fixed our problem.

Note You need to log in before you can comment on or make changes to this bug.