Bug 1049541 - The 2 displays are too big coming out of full-screen, from being configured from a 4 display setting.
Summary: The 2 displays are too big coming out of full-screen, from being configured f...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Default Assignee for SPICE Bugs
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 17:48 UTC by Bill Sanford
Modified: 2014-03-19 15:43 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-19 15:43:07 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Bill Sanford 2014-01-07 17:48:44 UTC
Description of problem:
I have 4 mingw displays on two physical monitors, using rhev-m (is30). The two physical monitors have a max resolution of 1920x1980. All 4 guest displays are set to 1440x900. I close virt-viewer. 

I then use the UP console to edit the launch to bring the VM in full-screen. The first two displays are up in full-screen and the last two displays are disabled in the Windows guest. Everything is perfect to this point. When I come out of full-screen the windowed displays are wider than the max resolution of the monitor screen, because of the borders of the VMs. The resolution of the windowed displays are 1920x1056. The virt-viewer windowed resolution adjusted for the vertical to fit in the max resolution of the client monitors, but the horizontal was not adjusted and it is bigger than the max resolution of the client monitors.

At this point, coming out of full-screen, this shouldn't negate the fact that the Windows guest resolution *was* set to 1440x900 initially, within the Windows guest. 

If the horizontal resolution on the virt-viewer displays are also adjusted to the max resolution of the client monitors like the vertical does, that could be an option and would be up to PM to make that call to have that option instead of setting it back to the original "Pre-UP" setting. 

Version-Release number of selected component (if applicable):
RHEV-M 3.3 (is30)
mingw-virt-viewer 0.5.6-16
Windows 7x64 - Client and guest

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Bill Sanford 2014-01-07 17:52:26 UTC
The original post of the max res of the monitors of 1920x1980 is really 1920x1080.

Comment 2 Marc-Andre Lureau 2014-03-04 18:28:24 UTC
I am unable to understand this bug.

In simple words, what is precisely the problem?

How do you reproduce it, with steps.

What do you expect it to do instead?

In normal usage, is this bug preventing usage of application or causing loss of data? If no, then severity should be reconsidered.

Since that seems to be a layout/windowing issue, could you provide a small video showing the problem?

thanks


Note You need to log in before you can comment on or make changes to this bug.