Bug 104978 - Perl will not upgrade
Perl will not upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-24 04:17 EDT by Stephen Lockley
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 15:42:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Lockley 2003-09-24 04:17:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Tried up2date -uf perl. I am getting the same error as before :-

I have tried to run up2date and have seleted Perl but I get the following 
error:-
  
There was a package dependency problem. The message was.  

Unresolvable chain of dependencies.
  
  Perl-5.8.0-88.3    requires perl-NDBM_file <= 1:1.75-34.99.6.
  
  I get this error on both of my servers.


More information. 

rpm -q perl
perl-5.8.0-88

rpm -q up2date
up2date-3.1.23.2-1



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.up2date --nox -uf perl
2.
3.
    

Actual Results:  There was a package dependency problem. The message was.  

Unresolvable chain of dependencies.
  
  Perl-5.8.0-88.3    requires perl-NDBM_file <= 1:1.75-34.99.6

Expected Results:  Updated

Additional info:
Comment 1 vivian_huang 2003-09-24 21:28:18 EDT
this is caused by the perl-NDBM_File not being removed on an upgrade from RH7.x
to RH8 or RH9.  The solution is to rpm -e perl-NDBM_File by hand; up2date should
then work.

Note You need to log in before you can comment on or make changes to this bug.