Bug 104991 - Damaged man pages
Summary: Damaged man pages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man-pages   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-24 13:55 UTC by Boris Folgmann
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version: 1.60-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 15:39:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Boris Folgmann 2003-09-24 13:55:28 UTC
Description of problem:
some man pages are damaged and can't be displayed

Version-Release number of selected component (if applicable):
man-pages-1.53-3

How reproducible:
always

Steps to Reproduce:
1. type "man fclose" or "man fcloseall" in the shell

    
Actual results:
$ man fclose
iconv: illegal input sequence at position 2277

$ man fcloseall
iconv: illegal input sequence at position 2281

Expected results:
format and show man page

Additional info:
rpm -V man-pages says that all files are ok.
Other man-pages are ok, but of course I didn't call all of them, so there may be
more that can't be displayed.

I suggest to add a check target (make check) for the Makefile if one exists
which checks all man sources if they can be formatted before you release a new
man-page rpm.

Comment 1 Eido Inoue 2003-09-24 14:38:45 UTC

*** This bug has been marked as a duplicate of 103214 ***

Comment 2 Boris Folgmann 2003-09-24 20:02:06 UTC
Tnx. RH rulez!



Note You need to log in before you can comment on or make changes to this bug.