Bug 1051375 - If multiple beans.xml files exist in a war deployed in an EAR all CDI beans will be registered twice
Summary: If multiple beans.xml files exist in a war deployed in an EAR all CDI beans w...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR0
: EAP 6.3.0
Assignee: Stuart Douglas
QA Contact: Marek Schmidt
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-10 07:56 UTC by Stuart Douglas
Modified: 2014-11-10 08:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous version of EAP 6, when an EAR deployment contained a WAR subdeployment with multiple beans.xml files, e.g. in WEB-INF/beans.xml and WEB-INF/classes/META-INF/beans.xml, all beans would be registered twice and the deployment would fail. This has been fixed by ammending the deployment processor to take this possibility into account and such deployments no longer fail to deploy.
Clone Of:
Environment:
Last Closed: 2014-06-28 15:41:18 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBEAP-31 Major Resolved WELD-001414 Bean name is ambiguous (but only one class reported) 2015-12-16 19:13:27 UTC

Description Stuart Douglas 2014-01-10 07:56:10 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Stuart Douglas 2014-01-10 07:57:49 UTC
Same issue as https://bugzilla.redhat.com/show_bug.cgi?id=921816 however due to a bug in the original fix this was not fixed for EAR deployments.

Comment 3 JBoss JIRA Server 2014-01-10 08:03:39 UTC
Stuart Douglas <stuart.w.douglas@gmail.com> updated the status of jira JBEAP-31 to Resolved

Comment 4 Marek Schmidt 2014-02-21 11:13:42 UTC
Verified on EAP 6.3.0.DR0


Note You need to log in before you can comment on or make changes to this bug.