Bug 10519 - Linuxconf Crashes after using it in Gnome with Enlightenment
Linuxconf Crashes after using it in Gnome with Enlightenment
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gnome-linuxconf (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-02 09:14 EDT by andreab
Modified: 2007-04-18 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-18 05:55:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andreab 2000-04-02 09:14:35 EDT
To: submit@bugs.gnome.org
From: Andrea Borghi <andreab@compuserve.com>
Subject: linuxconf crashes everytime I try to use it in Gnome
X-Mailer: bug-buddy 0.7

Package: general
Severity: normal
Version: (null)

>Synopsis: linuxconf crashes everytime I try to use it in Gnome
>Class: sw-bug
System: Linux 2.2.14-5.0 i686 unknown
C library: glibc-2.1.3-15
C compiler: egcs-2.91.66
glib: 1.2.6
GTK+: 1.2.6
ORBit: ORBit 0.5.0
gnome-libs: gnome-libs 1.0.55
gnome-core: gnome-core-1.0.55-12


>Description:
Everytime I try to launch Linuxconf it crashes .


>How-To-Repeat:
Try to install gnome with enlightenment and try to start linuxconf
in the env. after a while you work with it , when you want to submit a
change it crashes


Debugging information:
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x4045a8e9 in __wait4 () from /lib/libc.so.6
#0  0x4045a8e9 in __wait4 () from /lib/libc.so.6
#1  0x404b91ec in ?? () from /lib/libc.so.6
#2  0x40084591 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#3  0x403e7c68 in __restore ()
    at ../sysdeps/unix/sysv/linux/i386/sigaction.c:127
#4  0x40422fba in __libc_free (mem=0x80b4d60) at malloc.c:3023
#5  0x403b335d in g_free () from /usr/lib/libglib-1.2.so.0
#6  0x804c4bd in parse_get_tree_path ()
#7  0x804c594 in parse_get_tree_path ()
#8  0x804c7d2 in parse_get_tree_path ()
#9  0x804c89b in parse_line ()
#10 0x804edef in read_string ()
#11 0x4026f1eb in gdk_io_invoke () from /usr/lib/libgdk-1.2.so.0
#12 0x403b0aca in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#13 0x403b2186 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#14 0x403b2751 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#15 0x403b28f1 in g_main_run () from /usr/lib/libglib-1.2.so.0
#16 0x401c55b9 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#17 0x804f060 in main ()
#18 0x403e19cb in __libc_start_main (main=0x804eef0 <main>, argc=3,
    argv=0xbffffe74, init=0x804aaa8 <_init>, fini=0x804f0ac <_fini>,
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffffe6c)
    at ../sysdeps/generic/libc-start.c:92
#0  0x4045a8e9 in __wait4 () from /lib/libc.so.6
No locals.
#1  0x404b91ec in ?? () from /lib/libc.so.6
No symbol table info available.
#2  0x40084591 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
No symbol table info available.
#3  0x403e7c68 in __restore ()
    at ../sysdeps/unix/sysv/linux/i386/sigaction.c:127
No locals.
#4  0x40422fba in __libc_free (mem=0x80b4d60) at malloc.c:3023
mem = (void *) 0xbffffac8
ar_ptr = (arena *) 0x80b4d58
p = 0x0
#5  0x403b335d in g_free () from /usr/lib/libglib-1.2.so.0
No symbol table info available.
#6  0x804c4bd in parse_get_tree_path ()
No symbol table info available.
#7  0x804c594 in parse_get_tree_path ()
No symbol table info available.
Comment 1 Nalin Dahyabhai 2000-04-05 12:44:59 EDT
This looks like a bug in the gnome-linuxconf front-end for LinuxConf.
Comment 2 Nalin Dahyabhai 2000-04-06 19:07:59 EDT
Per private email:
> You are telling me it's a bug in the gui interface,
> how I can solve it?

I don't know that you can -- it's a bug in the particular front-end that hasn't
been fixed yet (6.2 includes the latest version available).  I was just noting
it when I changed the component to the proper package.
Comment 3 Kjartan Maraas 2004-03-29 15:29:17 EST
Can we get this closed now?

Note You need to log in before you can comment on or make changes to this bug.