Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1052196 - [RHEVH] cron job gets removed during upgrading RHEVH 3.2 to RHEVH 3.3
Summary: [RHEVH] cron job gets removed during upgrading RHEVH 3.2 to RHEVH 3.3
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor
Version: 3.3.0
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
: 3.4.0
Assignee: Fabian Deutsch
QA Contact: sefi litmanovich
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 13:28 UTC by Martin Pavlik
Modified: 2016-11-16 16:16 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-12 14:06:16 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
log_collector (15.39 MB, application/x-xz)
2014-01-13 13:28 UTC, Martin Pavlik
no flags Details

Description Martin Pavlik 2014-01-13 13:28:24 UTC
Created attachment 849366 [details]
log_collector

Description of problem:
cron job gets removed during upgrading RHEVH 3.2 to RHEVH 3.3

Version-Release number of selected component (if applicable):
before upgrade Red Hat Enterprise Virtualization Hypervisor release 6.5 (20131115.0.3.2.el6_5)

after upgrade
rhev-hypervisor6-6.5-20140112.0.el6ev

RHEVM used: 
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.44.el6ev 


How reproducible:
100%

Steps to Reproduce:
1)
Install RHEV-H via PXE
[root@localhost ~]# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 6.5 (20131115.0.3.2.el6_5)

2) add RHEV-H to 3.3 RHEV-M with 3.2 DC and 3.2 CL


3) add cron job in /var/spool/cron/root and persist the file
[root@localhost ~]# crontab -l
* * * * * echo `date` > /tmp/test

4) install rhev-hypervisor6-6.5-20140112.0.el6ev.noarch.rpm on RHEVM and upgrade RHEV-H via RHEVM GUI


Actual results:
after reboot crontab is empty

Expected results:
[root@localhost ~]# crontab -l
* * * * * echo `date` > /tmp/test

Additional info:

this is seems to be related to bug 1035804

Comment 1 Fabio Massimo Di Nitto 2014-01-13 13:50:12 UTC
Based on Fabian´s input, we don´t support installation of custom cron jobs.

Already the upgrade from 3.1 to 3.2 (or 3.2 to 3.3) used to wipe cronjobs to make space for the reboot entry to be removed later.

Comment 2 Ying Cui 2014-01-14 10:50:03 UTC
RHEV build only.

Tested PASS on RHEV-H base image(rhevh-6.5-20140110.1) both TUI and cmdline upgrade, no such issue. cron persisted yet.

Tested Failed on RHEV-H for rhev3.3 build(rhev-hypervisor6-6.5-20140112.0.el6ev) upgrading by RHEV-M. cron setting is not persisted.

So this is RHEV build only bug.

Comment 3 Fabian Deutsch 2014-02-04 13:36:06 UTC
This is actually a bug in RHEV-H 6.4s reboot code.

The codebase of RHEV-H 6.4 used cron to reboot. On 6.5 this function does not exist anymore.
And we can not fix this on 6.4. Besides that cronjobs are not supported on RHEV-H.

Martin,

did a customer run into his?

Comment 4 Martin Pavlik 2014-02-04 14:03:37 UTC
(In reply to Fabian Deutsch from comment #3)
> This is actually a bug in RHEV-H 6.4s reboot code.
> 
> The codebase of RHEV-H 6.4 used cron to reboot. On 6.5 this function does
> not exist anymore.
> And we can not fix this on 6.4. Besides that cronjobs are not supported on
> RHEV-H.
> 
> Martin,
> 
> did a customer run into his?

No customer did not run into this

Comment 5 Fabian Deutsch 2014-02-05 10:52:20 UTC
Right.

Then I'd say we close this as CURRENTRELEASE, as this doesn't exist in 6.5 anymore. (Reminder: The cron file is overwritten by the 6.4 logic).

Comment 10 sefi litmanovich 2014-05-12 12:38:22 UTC
Verified with rhevm-3.4.0-0.18.el6ev.noarch.

1. installed rhev-h rhevh-6.5-20140423.0.el6ev.iso on engine.
2. added crontab job on the host as per description.
3. upgrade host to latest rhev-h : rhevh-6.5-20140508.0.el6ev.iso
4. upgrade was successfull
5. crontab job remain the same.

Comment 11 Itamar Heim 2014-06-12 14:06:16 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.