This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 10524 - gnomecal crash
gnomecal crash
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnome-pim (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-02 15:29 EDT by Steve Philp
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-08 11:18:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Philp 2000-04-02 15:29:38 EDT
Fresh installation of Zoot.  Selecting gnomecal from the GNOME menu results
in a crash.

Here's the gnomebug report:

To: submit@bugs.gnome.org
From: Steve Philp <sphilp@ameritech.net>
Subject: gnomecal crash
X-Mailer: bug-buddy 0.7

Package: gnomecal
Severity: critical
Version: 1.0.55

>Synopsis: gnomecal crash
>Class: sw-bug
Distribution: Red Hat Linux release 6.2 (Zoot)
System: Linux 2.2.14-5.0smp i686 unknown
C library: glibc-2.1.3-15
C compiler: egcs-2.91.66
glib: 1.2.6
GTK+: 1.2.6
ORBit: ORBit 0.5.0
gnome-libs: gnome-libs 1.0.55
gnome-core: gnome-core-1.0.55-12


>Description:
This is a brand new installation of Zoot.  When Calendar is selected
from the Applications menu, a crash occurs.


>How-To-Repeat:
Start GNOME, click Foot, click Applications, click Calendar


Debugging information:
(no debugging symbols found)...0x404d78e9 in __wait4 () from /lib/libc.so.6
#0  0x404d78e9 in __wait4 () from /lib/libc.so.6
#1  0x405361ec in ?? () from /lib/libc.so.6
#2  0x40101591 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#3  0x40464c68 in __restore ()
    at ../sysdeps/unix/sysv/linux/i386/sigaction.c:127
#4  0x805fe3d in gncal_full_day_get_day_start_yoffset ()
#5  0x805af03 in gncal_day_panel_get_type ()
#6  0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
#7  0x402715fd in gtk_handlers_run () from /usr/lib/libgtk-1.2.so.0
#8  0x40270a42 in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#9  0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#10 0x402a2b98 in gtk_widget_size_allocate () from /usr/lib/libgtk-1.2.so.0
#11 0x4029a4a5 in gtk_viewport_size_allocate () from
/usr/lib/libgtk-1.2.so.0
#12 0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
#13 0x402708fb in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#14 0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#15 0x402a2b98 in gtk_widget_size_allocate () from /usr/lib/libgtk-1.2.so.0
#16 0x4026bf8f in gtk_scrolled_window_size_allocate ()
   from /usr/lib/libgtk-1.2.so.0
#17 0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
#18 0x402708fb in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#19 0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#20 0x402a2b98 in gtk_widget_size_allocate () from /usr/lib/libgtk-1.2.so.0
#21 0x402818e7 in gtk_table_size_allocate_pass2 ()
   from /usr/lib/libgtk-1.2.so.0
#22 0x40280554 in gtk_table_size_allocate () from /usr/lib/libgtk-1.2.so.0
#23 0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
#24 0x402708fb in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#25 0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#26 0x402a2b98 in gtk_widget_size_allocate () from /usr/lib/libgtk-1.2.so.0
#27 0x4024d5d0 in gtk_notebook_size_allocate () from
/usr/lib/libgtk-1.2.so.0
#28 0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
#29 0x402708fb in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#30 0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#31 0x402a2b98 in gtk_widget_size_allocate () from /usr/lib/libgtk-1.2.so.0
#32 0x400e0e52 in gnome_dock_size_allocate () from
/usr/lib/libgnomeui.so.32
#33 0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
#34 0x402708fb in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#35 0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#36 0x402a2b98 in gtk_widget_size_allocate () from /usr/lib/libgtk-1.2.so.0
#37 0x402987b4 in gtk_vbox_size_allocate () from /usr/lib/libgtk-1.2.so.0
#38 0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
#39 0x402708fb in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#40 0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#41 0x402a2b98 in gtk_widget_size_allocate () from /usr/lib/libgtk-1.2.so.0
#42 0x402aadb9 in gtk_window_size_allocate () from /usr/lib/libgtk-1.2.so.0
#43 0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
#44 0x402708fb in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#45 0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#46 0x402a2b98 in gtk_widget_size_allocate () from /usr/lib/libgtk-1.2.so.0
#47 0x402aa5f0 in gtk_window_show () from /usr/lib/libgtk-1.2.so.0
#48 0x400b90cf in gnome_app_show () from /usr/lib/libgnomeui.so.32
#49 0x40243efd in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0
#50 0x402708fb in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#51 0x4026eb95 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#52 0x402a058c in gtk_widget_show () from /usr/lib/libgtk-1.2.so.0
#53 0x8067c16 in save_default_calendar ()
#54 0x80683ae in main ()
#55 0x4045e9cb in __libc_start_main (main=0x80681e0 <main>, argc=1,
    argv=0xbffffa14, init=0x80506e4 <_init>, fini=0x807218c <_fini>,
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffffa0c)
    at ../sysdeps/generic/libc-start.c:92
#0  0x404d78e9 in __wait4 () from /lib/libc.so.6
No locals.
#1  0x405361ec in ?? () from /lib/libc.so.6
No symbol table info available.
#2  0x40101591 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
No symbol table info available.
#3  0x40464c68 in __restore ()
    at ../sysdeps/unix/sysv/linux/i386/sigaction.c:127
No locals.
#4  0x805fe3d in gncal_full_day_get_day_start_yoffset ()
No symbol table info available.
#5  0x805af03 in gncal_day_panel_get_type ()
No symbol table info available.
#6  0x40243d25 in gtk_marshal_NONE__POINTER () from
/usr/lib/libgtk-1.2.so.0
No symbol table info available.
#7  0x402715fd in gtk_handlers_run () from /usr/lib/libgtk-1.2.so.0
No symbol table info available.
Comment 1 Elliot Lee 2000-07-17 16:56:17 EDT
Cannot reproduce & old bug.

Note You need to log in before you can comment on or make changes to this bug.